Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Bug détecté après MAJ 1.92+

Bug détecté après MAJ 1.92+ 2 years 3 weeks ago #84396

  • Philippe
  • Philippe's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 38
  • Thank you received: 1
  • Karma: 0
Bonjour à tous et particulièrement aux gurus.

Je pense que je me trompe d'endroit pour déclarer un bug que je viens de constater mais j'ai pas d'idée où mettre ça ailleurs...
--
- J'ai effectué une MAJ de la 1.91 vers la 1.92+ hier
- ça fonctionne correctement en apparence sauf qu'a l'examen des résultats j'ai un bug étrange :
- Pour tous mes questionnaires activés antérieurement à la MAJ, pour une nouvelle saisie à partir d'hier (MAJ) la date de dernière action et la date lancement (si elle était pas renseignée) se retrouve à 1980-01-01 00:00:00
- Par contre pour le questionnaire que j'ai activé hier après la MAJ ça fonctionne correctement et enregistre bien le bon horodatage...

Étrange n'est ce pas ?

Philippe
The administrator has disabled public write access.

Re: Bug détecté après MAJ 1.92+ 2 years 3 weeks ago #84407

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6277
  • Thank you received: 802
  • Karma: 241
Salut,

C'est pour des questionnaires terminé ?

On ne fait peut être plus les bon test pour mettre Y à terminé, je sais pas trop. Quand tu dis non renseigné : ce sont des questionnaires anonyme, c'est ça ?

Denis
The administrator has disabled public write access.

Re: Bug détecté après MAJ 1.92+ 2 years 3 weeks ago #84409

  • Philippe
  • Philippe's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 38
  • Thank you received: 1
  • Karma: 0
Bonjour Denis,

Non, ce sont des questionnaires toujours en activité, ouverts avant que je fasse la MAJ (hier) vers la 1.92+.
J'ai constaté le bug cette nuit quand un des questionnaires (qui est en activité depuis plus d'un an) a été rempli. J'ai vu cette date bizarre... Du coup j'ai fais des test et ça fait ça sur tous les questionnaires activés antérieurement à la MAJ 1.92+ (hier)
Par contre, le questionnaire que j'ai activé hier soir APRES la MAJ lui ne comporte pas ce bug, le champs se rempli de la bonne date.
---
Quand je dis non renseigné c'est à propos du 2ème champs de date ("date de lancement" dudit questionnaire) y en avait que je n'avais pas défini initialement et j'ai remarqué que dans ce champs ça mettait la même date que dans le champs "dernière action" (celui qui merdouille maintenant)...
---
Je vais regarder pour le "Y" de terminer mais il me semble (de mémoire) que le questionnaire de cette nuit était terminé = Y...

So bizarre...
Philippe
The administrator has disabled public write access.

Re: Bug détecté après MAJ 1.92+ 2 years 3 weeks ago #84413

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6277
  • Thank you received: 802
  • Karma: 241
Salut,

Il me semble que les champs "date de lancement" et dernière action sont sur des types date.

Les champs SQL de type date ont obligatoirement une date, je ne sais plus trop comment c'était avant.

Denis
The administrator has disabled public write access.

Re: Bug détecté après MAJ 1.92+ 2 years 3 weeks ago #84418

  • Philippe
  • Philippe's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 38
  • Thank you received: 1
  • Karma: 0
Re,

Effectivement il semble que ça toujours été des champs de type "date"...
Même maintenant, et je pense que c'est juste que c'est pas (plus) nourri et c'est pourquoi ça affiche maintenant 1980-01-01 00:00:00... Ce doit être la valeur minimale par défaut de ce type de champs...

Philippe
The administrator has disabled public write access.

Re: Bug détecté après MAJ 1.92+ 2 years 3 weeks ago #84427

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6277
  • Thank you received: 802
  • Karma: 241
Salut,

La valeur minimum dépend du serveur, donc les dev ont décidé de la passer à 1980-01-01 00:00:00.

Par contre, on ne devrait pas l'afficher, cela devait être le cas sur la 1.91.

Tu peux remonter le bug ? Pas urgent mais à prévoir.

Denis
The administrator has disabled public write access.

Re: Bug détecté après MAJ 1.92+ 2 years 3 weeks ago #84429

  • Philippe
  • Philippe's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 38
  • Thank you received: 1
  • Karma: 0
Heu, juste par ce que c'est ma "première fois"
Comment je fais pour "remonter le bug" ? Y a une petite clé dans le dos ? B)
C'est dans la page d'accueil du forum ? en anglais ?
Philippe
The administrator has disabled public write access.

Re: Bug détecté après MAJ 1.92+ 2 years 3 weeks ago #84436

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6277
  • Thank you received: 802
  • Karma: 241
Salut,

Tu peux te connecter avec le même compte que celui du forum.
www.limesurvey.org/fr/communaute/suivi-de-bugs

Par contre, c'est vrai qu'il faut rapporter en anglais.

Denis
The administrator has disabled public write access.

Re: Bug détecté après MAJ 1.92+ 2 years 3 weeks ago #84464

  • Philippe
  • Philippe's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 38
  • Thank you received: 1
  • Karma: 0
Bonjour,
Bon, c'est fait. Du coup j'ai un peut cherché sur le forum des bug car il semble qu'il y en ait un identique dans la RC de la 2.0 dont le fil parlait de format de date (yyyy/mm/dd versus le notre)
J'ai un peu testé différent format proposé mais le problème reste identique.
Donc j'ai rapporté...
A Bientôt
Philippe
The administrator has disabled public write access.

Re: Bug détecté après MAJ 1.92+ 1 year 7 months ago #90698

  • lemontree
  • lemontree's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 29
  • Karma: 0
Bonjour,

Je viens de tomber sur le même cas de figure que toi, en réactivant un questionnaire et entre temps j'avais dû changer de version, je suis désormais en Version 1.92+ Build 120919

Avais-tu trouvé une solution ?
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: Nickko
Time to create page: 0.122 seconds
Donation Image