Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: [Résolu] Ne pas afficher un groupe de questions ... vide

[Résolu] Ne pas afficher un groupe de questions ... vide 3 years 10 months ago #53398

  • hertay
  • hertay's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 19
  • Karma: 0
Bonjour,

version 1.90 + 9229

Par le jeu des questions/réponses, une catégorie de questionnés n'est pas concernée par les questions du groupe X. Mais le groupe X s'affiche, avec son intitulé et ne présente, bien entendu, aucune question.

Est-il possible de ne pas afficher du tout le groupe et, dans l'affirmative, comment ?

Merci et bonne journée ;)
Last Edit: 3 years 9 months ago by DenisChenu. Reason: Balise [Résolu]
The administrator has disabled public write access.

Re:Ne pas afficher un groupe de questions ... vide 3 years 10 months ago #53426

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
Salut,

As tu mis la condition sur toutes les questions du groupe ?

Au cas ou, peut tu nous mettre un export du questionnaire ?

Normalement le groupe ne devrait pas s'afficher :(
The administrator has disabled public write access.

Re:Ne pas afficher un groupe de questions ... vide 3 years 10 months ago #53487

  • hertay
  • hertay's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 19
  • Karma: 0
Shnoulle wrote:
As tu mis la condition sur toutes les questions du groupe ?
Oui mais je vais revoir ma copie car il y a plusieurs conditions et peut-être se télescopent-elles ? ;)
Au cas ou, peut tu nous mettre un export du questionnaire ?
Oui, si je n'ai pas trouvé la solution. Merci
Normalement le groupe ne devrait pas s'afficher :(
C'est aussi ce que j'avais déjà observé d'où ma surprise ...
Cf pièce jointe.
bdc_50.jpg
Last Edit: 3 years 10 months ago by hertay.
The administrator has disabled public write access.

Re: Ne pas afficher un groupe de questions ... vide 3 years 9 months ago #55581

  • Philippe
  • Philippe's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 38
  • Thank you received: 1
  • Karma: 0
Bonjour à toutes z'et tous,

Je me permet de remonter ce topic car je constate exactement le même problème.
Dans ce fil de discussion il n'y a pas eu de suite il me semble ?
Et pour faire avancer le sujet j'ai moi aussi plusieurs conditions mais elles ne se téléscopent pas (elle sont à la suite)
Et mes groupes apparaissent vide alors que les questions non.
C'est bien génant en fait car j'ai 5 groupes derrière une question...
Quelqu'un aurait il une idée ?
Bonne journée et merki !

Philippe
The administrator has disabled public write access.

Re: Ne pas afficher un groupe de questions ... vide 3 years 9 months ago #55582

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
Salut Philippe,

En fait, pourrais tu envoyer un export du questionnaire.

Tu utilise le template par défaut ? En groupe par groupe ou question par question ?
The administrator has disabled public write access.
The following user(s) said Thank You: Philippe

Re: Ne pas afficher un groupe de questions ... vide 3 years 9 months ago #55585

  • Philippe
  • Philippe's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 38
  • Thank you received: 1
  • Karma: 0
Bonjour,

Quelle réactivité !
Voici donc en PJ l'export du questionnaire.
Pour répondre aux autres questions il s'agit d'un template personnalisé mais j'ai testé avec le template par défault et ça fait la même chose.
Le fonctionnement est groupe par groupe
Amicalement
Philippe

File Attachment:

File Name: limesurvey_survey_76947.lss
File Size: 196 KB
The administrator has disabled public write access.

Re: Ne pas afficher un groupe de questions ... vide 3 years 9 months ago #55586

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
Salut,

Si je comprend bien, par exemple pour la série de questions Q10XX, elle ne devrait être affichée que si :
Q-730: Avez-vous utilisé le système de Jet-Ventilation (Manujet) ? (qid4735) Égal Oui (Y)

Or la question:
Q1020 bis:
Question: La ventilation grace au système de Jet Ventilation était efficace ?

est affichée avec uniquement :
Q-1020: La mise en place de la Jet Ventilation a-t-elle été un succès ? (qid4747) Égal Oui (Y)

La question Q-1020 n'est pas affichée, cependant LS ne le sait pas pour la 1020 bis, il ne va pas chercher si les questions précédentes sont affichée ou non. Il ne fait que le test sur les questions directes.

Donc tu ajoute le test sur la Q-730 sur TOUTES les questions du groupes. Mêmes sur les questions qui ont déjà une condition "découlante".

Ca devrait le faire. :)
Last Edit: 3 years 9 months ago by DenisChenu.
The administrator has disabled public write access.

Re: Ne pas afficher un groupe de questions ... vide 3 years 9 months ago #55593

  • Philippe
  • Philippe's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 38
  • Thank you received: 1
  • Karma: 0
YESSSSSSS !!!!!
:woohoo:
Et encore merci !
C'est exactement ce "détail" qui bloquait, j'avais pas dû bien lire le mode d'emploi...
--
En tout cas encore merci de votre aide.
On peut mettre le sujet à "Résolu" (mais moi je peux pas...)
Bonne soirée
Philippe
The administrator has disabled public write access.

Re: Ne pas afficher un groupe de questions ... vide 3 years 9 months ago #55597

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
Merci de votre retour !

Si ces informations vous ont aidé et que vous aimez LimeSurvey
veuillez considérer l'opportunité d'une donation au projet .
Le projet LimeSurvey est effectué sur notre temps libre et nous ne recevons aucune rémunération.

Sans votre aide , le projet ne peut survivre.

Pour la balise, c'est fait. En même temps, on a rien d'officiel sur les balises :)
The administrator has disabled public write access.

Re: Ne pas afficher un groupe de questions ... vide 3 years 7 months ago #57626

  • hertay
  • hertay's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 19
  • Karma: 0
Philippe wrote:
[...]On peut mettre le sujet à "Résolu" (mais moi je peux pas...)[...]

Normal car je suis l'auteur de la question et mon problème (identique à celui de Philippe) n'est pas résolu ;)
J'ai essayé de transposer mais je préfère les conseils adaptés de Schnoulle pour parvenir au miracle :)
En pièce jointe, l'export du questionnaire ...

Merci !

File Attachment:

File Name: limesurvey_survey_63859.lss
File Size: 186 KB
Last Edit: 3 years 7 months ago by hertay.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: Nickko
Time to create page: 0.138 seconds
Donation Image