Welcome, Guest
Username: Password: Remember me

TOPIC: Caracteres accentués dans résultats HTML

Caracteres accentués dans résultats HTML 4 years 2 weeks ago #49819

  • triplebuz
  • triplebuz's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Bonsoir,

lors de la consultation des résultats dans limesurvey avec graphique et en HTML, les caracteres accentués sont mal interprétés ou vides. J'ai essayé sur plusieurs navigateurs....meme probleme.

Merci par avance de votre aide !
The administrator has disabled public write access.

Re:Caracteres accentués dans résultats HTML 4 years 2 weeks ago #49836

  • Nickko
  • Nickko's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2123
  • Thank you received: 261
  • Karma: 56
Pourrait-on avoir une copie d'écran ou plus d'explication ?
Est-ce que ça concerne tous les caractères ?
Est-ce que si tu regardes les resultats autrement as-tu le même pb ?
Et en PDF ?

Quelle version et quelle build de LimeSurvey ?
Ne serait-ce pas un pb de type dans la DB ?
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Re:Caracteres accentués dans résultats HTML 4 years 2 weeks ago #49840

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6429
  • Thank you received: 840
  • Karma: 249
Je penche plutôt pour un problème coté serveur, pour apache : httpd.apache.org/docs/2.0/mod/core.html#adddefaultcharset.

Sinon, il existe cette manip quand cela traduit mal :
docs.limesurvey.org/tiki-index.php?page=...g_Functions_library_

Et la suite aussi d'ailleurs. Il faut que l'on en sache plus sur les charset actuel.
The administrator has disabled public write access.

Re:Caracteres accentués dans résultats HTML 4 years 2 weeks ago #49870

  • triplebuz
  • triplebuz's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Merci de vos réponses.

en effet mon post manque de précision, Limesurvey est installé sur un Xampp porté par un Windows server 2003.
Version de Limesurvey : 1.90+ Build 9089,
Apache : * Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1
Mysql :Version du serveur: 5.1.41, eu de caractères pour MySQL: UTF-8 Unicode (utf8)

J'ai vérifié, les bases sont bien en utf8_unicode_ci

Et voici un exemple de caractère posant probleme :
01_10_2010_14_24_56.png
The administrator has disabled public write access.

Re:Caracteres accentués dans résultats HTML 4 years 2 weeks ago #49906

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6429
  • Thank you received: 840
  • Karma: 249
Essaye une Maj de LS (actuel 9160).

Essaye dans le php.ini :
AddDefaultCharset utf-8
The administrator has disabled public write access.

Re:Caracteres accentués dans résultats HTML 4 years 2 weeks ago #50095

  • triplebuz
  • triplebuz's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Maj de LS effectuée, httpd.conf modifié avec AddDefaultCharset utf-8 mais meme probleme. J'ai meme du coup des caractères accentués de l'interface qui ne sont plus interprétés.
The administrator has disabled public write access.

Re:Caracteres accentués dans résultats HTML 4 years 2 weeks ago #50137

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6429
  • Thank you received: 840
  • Karma: 249
Peux-tu vérifer avec différents encodage.

Le problèmes des caractères accentué est souvent liés à des problèmes de serveur. Nous essayons d'avoir le système le plus compatible possible, mais bon.

Essaye avec FireFox , puis Affichage/Encodage des caractères/...

Tu peux éventuellment compléter les rapports de bug suivant:
bugs.limesurvey.org/view.php?id=4289
bugs.limesurvey.org/view.php?id=4358

le 4289 est celui d'ouvert

Il faudras sans doute avoir le max d'info sur la config de ton serveur.
The administrator has disabled public write access.
Moderators: Nickko
Time to create page: 0.170 seconds
Donation Image