Welcome, Guest
Username: Password: Remember me

TOPIC: Could not create database (root)

Could not create database (root) 2 years 6 months ago #71260

  • mixbart
  • mixbart's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Bij het installeren van de database kreeg ik de onderstaande foutmelding in de browser:

Create database
Creating tables. This might take a moment...

Error
Could not create database (root)
Access denied for user ''@'localhost' to database 'root'


gegevens van mijn installatie:
-fysieke adres Limesurvey --> c:\xampp\htdocs\limesurvey_dev


Kan iemand mij hier aub mee helpen?


vriendelijke groeten,
Bart
Last Edit: 2 years 6 months ago by mixbart.
The administrator has disabled public write access.

Re: Could not create database (root) 2 years 6 months ago #71273

  • fransmarcelissen
  • fransmarcelissen's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 128
  • Thank you received: 17
  • Karma: 5
Mijn antwoord is waarschijnlijk te simpel (excuses dan), maar dit betekent meestal dat je óf in config.sys niet de goede databasegegevens opgegeven hebt (verkeerde databasenaam, verkeerde gebruiker/wachtwoord), óf dat de gebruiker geen rechten heeft om een database aan te maken. Heb je dit allemaal uitgesloten? Ik vind het trouwens zelf veiliger en handiger om zelf in mysql een database aan te maken, en deze (bestaande) database op te geven (dan worden alleen tabellen gemaakt).
config.sys moet in ieder geval de admin gegevens, de database gegevens em waarschijnlijk de mail gegevens bevatten. De rest kan later wel.
Overigens weet ik niet welke versie van limesurvey je installeert: bij de nieuwe 1.92rc1 ging het ook niet helemaal goed, er werd geen admin aangemaakt. Ik heb die handmatig aangemaakt.
Groet
Frans
The administrator has disabled public write access.

Re: Could not create database (root) 2 years 6 months ago #71279

  • mixbart
  • mixbart's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hoi Frans,

Bedankt voor de reactie. Er moest inderdaad iets aangepast worden aan config.php.
Bij $databaseuser stond niks ingevuld en daar heb ik de al in Mysql bestaande user "root" ingevuld.

groet,
Bart
The administrator has disabled public write access.
Time to create page: 0.107 seconds
Donation Image