Welcome, Guest
Username: Password: Remember me

TOPIC: Proxypass werkt maar half meer sinds update van 1.87 naar 1.91+

Proxypass werkt maar half meer sinds update van 1.87 naar 1.91+ 3 years 1 month ago #62710

Limesurvey werd tot vorige week gehost op een interne server

local.someserver.be/limesurvey

externe gebruikers konden hiervan gebruik maken langs onze externe server via proxypass

external.server.be/limesurvey

Dit werkte perfect op 1.87

Vorige woensdag hebben we een update gedaan naar 1.91+ en nu blijkt sommige delen van limesurvey de proxypass NIET meer te gebruiken.

de administratiemodule is perfect bereikbaar en bruikbaar via external.server.be/limesurvey/admin/admin.php

Maar op de landingspagina external.server.be/limesurvey verwijzen alle publieke enquêtes opeens naar local.someserver.be/limesurvey/index.php?sid=de_enquête_id ipv external.server.be/limesurvey/index.php?sid=de_enquête_id zoals VOOR de update

Hebben we iets verkeer gedaan ? of zit er een bug in 1.91+ ? ik heb een oude bug gevonden die zeer gelijkaardig gedrag beschrijft op bugs.limesurvey
om dat te vermijden proxypass'den (is this a verb ? o_O) we vroeger ook al de identieke directory...

De update naar 1.91+ was nodig omdat er een exploit zat in 1.87...

Help ?
The administrator has disabled public write access.

Re: Proxypass werkt maar half meer sinds update van 1.87 naar 1.91+ 3 years 1 month ago #62736

Ignore previous rant, er moet iets verkeerd gegaan zijn in de apache van de proxypasserende server

Maar wie ooit een gelijkaardig probleem heeft : het is imperatief om in de configuratie van de front end server NAAST je proxypass en proxypassreverse ook de volgende twee directives mee te geven als je je surveys (ook) via SSL wenst aan te bieden :

SSLProxyEngine On
ProxyPreserveHost On
The administrator has disabled public write access.
Time to create page: 0.109 seconds
Donation Image