Welcome, Guest
Username: Password: Remember me

TOPIC: Modifying to Add Feature - Getting "Page Not Found"

Modifying to Add Feature - Getting "Page Not Found" 8 months 4 weeks ago #98308

  • jmadero
  • jmadero's Avatar
Hi All -

I'm in the initial stages of modifying LimeSurvey to suit very particular needs of a project I'm working on. I am in the very very early stages so apologies for the basic question(s)

I am trying to add a new feature so I successfully created a new icon in the admin menu called "Create New Polling Site" - icon appeared perfectly when I added the appropriate lines in ADMINMENU.php

Then I have:

<a href="<?php echo $this->createUrl("admin/pollinglocations/sa/index"); ?>">

I copied all of user content (admin/user) to be used as a template for the new feature to admin/pollinglocation but when I click the new icon I get a "page not found" error.

Furthermore as test I changed admin/user to admin/user1 and updated ADMINMENU.php to user1 instead of user for "Manage Survey Administrators" and I get the same page not found error.


I guess I am looking for the files I need to touch in order to be able to add functions to LimeWire.

Very early on but already really impressed with this software - it does about 50% of what I was thinking about doing from scratch as a personal project so - hopefully with some heavy modifications I can get it there :) Thanks in advance
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.080 seconds
Donation Image