Welcome, Guest
Username: Password: Remember me

TOPIC: Repository not cloning due to permissions

Repository not cloning due to permissions 1 year 11 months ago #90209

Hi! I am non-technical and I'm gingerly trying to follow the instructions to create a new language pack for a research project. I've done the bits with Git and Smart Git but the respository won't clone: I'm just getting a load of permission errors. I had to create the 'Limesurvey' folder manually so I guess I have some permissions problem on my system? Is there any way around this?
The administrator has disabled public write access.

Re: Repository not cloning due to permissions 1 year 11 months ago #90218

Right, I figured that it was the Windows Read-Only bug that was causing the mayhem, so I ran this at the command line:

attrib –r -s "c:\Program Files (x86)\SmartGit 3\bin\*" (with and without the \*)

But the bin folder is still coming up as read only. Also, if I try to clone, I'm getting a warning that the destination path already exits and is not an empty directory. I guess that some kind of ghost version from previous attempts is hanging around?
The administrator has disabled public write access.

Re: Repository not cloning due to permissions 1 year 11 months ago #90228

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6551
  • Thank you received: 868
  • Karma: 257
Hello,

You want to do a langage pack for communauty ? For what langage ?

If it's for an inexisting language for the LS core system, put a bug report . After language can be adding to translate.limesurvey.org/projects/limesurvey2 and you can translate more easily here.

You can send a post to This email address is being protected from spambots. You need JavaScript enabled to view it. .

For just a transaltion, you don't need GIT, but only the source files (uncompress sip), the po/mo files (from translate.limesurvey.org/projects/limesurvey2 [*]) and poedit.

Denis
* See export at end of your base language
Last Edit: 1 year 11 months ago by DenisChenu.
The administrator has disabled public write access.

Re: Repository not cloning due to permissions 1 year 11 months ago #90236

Even more exotic than Gaelic, Denis: the Sorani dialect of Kurdish, which is spoken in Iran and Iraq (ku;sdh). The guidance said I did need to get the source files (docs.limesurvey.org/Translating+LimeSurvey) but I did think it seemed a bit over the top to have to access the source code.

So, I'll ask the guys at your end to set up the directories via a bug-report, and then follow the instructions from Stage 6 and send my files via email. Fantastic: that sounds like something I can do!
The administrator has disabled public write access.

Re: Repository not cloning due to permissions 1 year 11 months ago #90279

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6551
  • Thank you received: 868
  • Karma: 257
The administrator has disabled public write access.

Re: Repository not cloning due to permissions 1 year 11 months ago #90309

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5423
  • Thank you received: 307
  • Karma: 252
GalloiseBlonde wrote:
So, I'll ask the guys at your end to set up the directories via a bug-report, and then follow the instructions from Stage 6 and send my files via email. Fantastic: that sounds like something I can do!
Please post the link to the bug ticket here so we can follow progress.

When you are done, you can simply attach the .po/.mo file at the bug ticket.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.109 seconds
Donation Image