Welcome, Guest
Username: Password: Remember me

TOPIC: Cloudflare.

Cloudflare. 2 years 11 months ago #69055

  • crh431
  • crh431's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
I'm entirely unsure as to where I should be posting this, but I am going to start here.
Recently I switched DNS providers to Cloudflare, which is free and offers quite a bit it in terms of security, caching, ipv6 compatibility, etc. I found that some feature of Cloudflare specifically breaks question editing functions - clicking the + sign to add a new answer doesn't do anything. I have played around with Cloudflare settings, specifically auto minify of .js and have yet to figure out the precise cause. It seems to me that minify should be the issue and that the Cloudflare cache just hasn't caught up with my settings. Sadly, I've done a cache purge on their servers a few times and it's been a few hours, so I'm losing hope on that.
For anyone experiencing the same issue, the simple fix is to install Limesurvey on a subdomain and turn off Cloudflare protection for the subdomain. Sucks, but works better.
The administrator has disabled public write access.

Re: Cloudflare. 2 years 11 months ago #69064

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5331
  • Thank you received: 296
  • Karma: 249
Thanks for your feedback. Please add your notes at manual ->installation FAQ.

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.099 seconds
Donation Image