Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: export to spss with internet explorer under HTTPS

export to spss with internet explorer under HTTPS 5 years 1 month ago #32293

  • jooghe
  • jooghe's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Dear,

Our limesurvey is accessed through https. It all works fine except for downloading the results in SPSS or R format. This problem only occurs with internet explorer. All other browsers I tested work fine.

When I click on the link to download the SPSS file IE prompts me to download server.xx/admin/admin.php?action=exports...ubaction=dlstructure instead of just the plain filename (eg survey_97274_SPSS_syntax_file.sps). When I click "Save" I got an error : "Internet Explorer cannot download admin.php from server" . So instead of letting me save the result of the request IE tries to save the script that executes the request.

When changing the HTTP header pragma from no-cache to cache or public it does work fine. So we could change that in the export scripts, but I'm not sure if this is the best solution, especially since it's only for IE that we need to change it. What do you think is it a save change ? Is there another solution,apart from telling the users to use another browser ? Anyone else had this problem ?

Thanks,
Jan.
The administrator has disabled public write access.

Re:export to spss with internet explorer under HTTPS 5 years 1 month ago #32300

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5426
  • Thank you received: 307
  • Karma: 252
1. Which Limesurvey version do you use?

2. Which IE version causes the problems?

3. Does everything work fine when using other borwsers like firefox?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:export to spss with internet explorer under HTTPS 5 years 1 month ago #32302

  • jooghe
  • jooghe's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Mazi,

We are working with LS 1.85+.
Both IE7 and IE8 give this problem.
Firefox, Mozilla and Chrome are working fine.

It seems to be related to support.microsoft.com/kb/812935 . So I centainly wouldn't call it a bug in limesurvey, it's more how to cope with certain IE "features" .

I found some discussions about this header problem in IE on be2.php.net/manual/en/function.header.php .

Seems like be2.php.net/manual/en/function.header.php#83219 is proposing a workable solution. But it involves turning on caching and I hope that this does not generate other problems.

I've posted it to check if anyone else has experience with it and also to document this behavior for Limesurvey.

Thanks,
Jan.
The administrator has disabled public write access.

Re:export to spss with internet explorer under HTTPS 5 years 1 month ago #32306

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5426
  • Thank you received: 307
  • Karma: 252
Please test if the problem still exists at the latest release. If so please open a ticket at the bugtracker and...

1. Give as much information as possible

2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.

3. Provide step-by-step instructions how to reproduce the problem.

4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:export to spss with internet explorer under HTTPS 5 years 1 month ago #32881

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
I suppose it is not only related to exports spps/r but to all downloads because it is a headers problem. Please confirm. I tried some of the fixes on my localhost install and got mixed results. Sometimes I was able to download but on a retry it failed again. Now I remember why I stopped using IE ;-)

When there proves to be no reliable way to fix this, it might be an idea to document workarounds in the docs that tell what settings to change in the browser. I don't have any experience with it myself, but a general page about https installs (what to change where) might be good.

Just for the record, I used IE8 on a local xampp install to test the fixes. Might be impossible, as some things just work different on localhost.

There used to be problems on every pageload (in the admin part) when https was on. Something about mixed content but that seems to be fixed in 1.86 release :)
---
Menno Dekker
Last Edit: 5 years 1 month ago by mdekker.
The administrator has disabled public write access.

Re:export to spss with internet explorer under HTTPS 5 years 1 month ago #32889

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5426
  • Thank you received: 307
  • Karma: 252
mdekker wrote:
When there proves to be no reliable way to fix this, it might be an idea to document workarounds in the docs that tell what settings to change in the browser. I don't have any experience with it myself, but a general page about https installs (what to change where) might be good.
I totally agree! Is there anybody running Limesurvey on https without problems who can share his/her experience? Any volunteers?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:export to spss with internet explorer under HTTPS 5 years 1 month ago #33014

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
I ran into problems with mixed content on 1.86 version. Every page on the admin part showed an error in IE6! The fix was to change something in the admin/scripts/tooltip.js

Line 45 reads:
dhtmlgoodies_iframe.src = '#';

and should be changed to:
dhtmlgoodies_iframe.src = 'javascript: false;';

I noticed in svn this file doesn't exist anymore. A test on 1.87 showed no fancy tooltips in IE6 but didn't have the problems with mixed content. So when 1.87 is released those problems shoulde be fixed. The download problems should still be checked.
---
Menno Dekker
Last Edit: 5 years 1 month ago by mdekker.
The administrator has disabled public write access.

Re:export to spss with internet explorer under HTTPS 4 years 6 months ago #41723

  • rom
  • rom's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Thank you received: 1
  • Karma: 0
I can confirm the SPSS File download issue of the OP by using https and Internet Explorer 7 and 8.

We used Limesurvey 1.72 (5737) for a long time, and we always had that problem. We updated our installation about 5 minutes ago to the most recent Version 1.87+ Build 8518, still the same issue.

There is no problem downloading the SPSS file using alternate Browsers like Firefox, only Internet Explorer 7/8 have this issue.


(offtopic edit: strange, i am still called a "fresh lemon"? we donated a while ago, and we got a promise that our forum status has been changed because of our donation... well, not that I care very much about it ;)

edit2: never mind, i just had to take a look into my profile... doh )
Last Edit: 4 years 6 months ago by rom.
The administrator has disabled public write access.

Re:export to spss with internet explorer under HTTPS 4 years 6 months ago #41728

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2961
  • Thank you received: 381
  • Karma: 124
Today the forum system seems to be a little mixed up.

I had moderator status yesterday, today I have Gold lime or something like that.

Maybe just a hickup of Joomla? ;-)
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:export to spss with internet explorer under HTTPS 4 years 6 months ago #41752

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5426
  • Thank you received: 307
  • Karma: 252
rom: Please open a ticket at the bugtracker and...

1. Give as much information as possible

2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.

3. Provide step-by-step instructions how to reproduce the problem.

4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.131 seconds
Donation Image