Welcome, Guest
Username: Password: Remember me

TOPIC: Resume Later function not working on a survey

Resume Later function not working on a survey 1 month 3 weeks ago #111868

  • klauri
  • klauri's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 15
  • Karma: 0
Hello,
We have been using LS for about 4 years to conduct program evaluation. I have not had issues with people using the Resume later/save function in the past. We recently decided to allow respondents to submit a monthly survey as a team, and told them if they could not complete it as a team, to start it and fill in what they could and then use the resume later function and share the link/password to the saved survey with their colleagues so they could complete the survey. I tested this approach on a survey before making the suggestion and had no issues with it.

One of the teams has continuously had issues with saving their survey. They use the resume later function and it seems to be submitting the survey (its time stamped in the data base as submitted). Its causing a great deal of frustration on the user end, and I am hoping there is an simple solution.

The last sets of questions in the survey are logic based and connected to an earlier question. When I tested this specific survey, I filled it in partially, and then saved it. When I used the link to access the saved survey it took me to a thanks for submitting your survey page. I had not hit submit nor had I went to the end of the survey. I am attaching a copy of the survey from the print view. Question 6 is connected to all of the following question sets based on logic.

Could there be an issue with saving a survey and the format of the last questions? What additional information might someone need to try to address this question? Please note, I am not a programmer, but rather a social scientist.

Thank you in advance for your time.
Kelly
The administrator has disabled public write access.

Resume Later function not working on a survey 1 month 3 weeks ago #111869

  • klauri
  • klauri's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 15
  • Karma: 0
Okay, I just did more detective work on another survey. This other survey saves with no problem, EXCEPT, if I have put in a response for all of the mandatory questions! When I fill in responses for all the mandatory questions and save, its saves and send the link, but when I access the link it says its been submitted. Could it be that you cant save a survey if all the mandatory questions have been answered? I wonder if the system is thinking its complete.
The administrator has disabled public write access.

Resume Later function not working on a survey 1 month 3 weeks ago #111881

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6435
  • Thank you received: 840
  • Karma: 249
What is your actual build ? There are some fix for SAVE under certain condition in the last release.
The administrator has disabled public write access.

Resume Later function not working on a survey 1 month 3 weeks ago #111895

  • klauri
  • klauri's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 15
  • Karma: 0
Version 1.92 RC5 Build 120225
The administrator has disabled public write access.

Resume Later function not working on a survey 1 month 3 weeks ago #111900

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2845
  • Thank you received: 358
  • Karma: 124
This isn't even a version that is supposed to be used for production!

RC stands for Release Candidate. This means it is almost there, but is not a final version.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
The following user(s) said Thank You: DenisChenu

Resume Later function not working on a survey 1 month 3 weeks ago #111938

  • klauri
  • klauri's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 15
  • Karma: 0
well that is frustrating! We have very little tech support on this project (obviously) and the institution that provides it is the one that updated our version we are running. Is there a recommendation you have for which version we use?

Also, we have a large number of active surveys at any given point and a large amount of data in LS, it always makes me nervous when we do an update. Is there any risk losing data/surveys etc, if we update? Can it be done easily or should someone (other than me) with a higher technical skill level do this?

I appreciate your help.
The administrator has disabled public write access.

Resume Later function not working on a survey 1 month 3 weeks ago #111948

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6435
  • Thank you received: 840
  • Karma: 249
Hi,

We can not gurantee any probel on update but :
- Make a backup of all files in the directory
- Make a backup of your database

And do the uddate : ther are less difference betwwen 1.92RC5 and last RC92 BUT tehre are security issue if you are not with the last version (2.05).

My method:
mv limesuvey limesurveybackup
wget limesurvey.zip
unzip limesurvey.zip
After copy the database with phpMyAdmin with another name
If you update to 1.92
cp limesurveybackup/config.php limesurvey/
mv limesurvey/install limesurvey/someradomcharacter
And after go to limesurvey admin directory and update.
after
cp -rf limesurveybackup/upload/* limesurvey/upload/
If update is OK, you can do the same for 2.00 and 2.05, but no need to cp config.php : just launch the install process and put the good information for DB

Denis
The administrator has disabled public write access.

Resume Later function not working on a survey 1 month 3 weeks ago #111951

  • klauri
  • klauri's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 15
  • Karma: 0
Thank you so much for your help & patience with this issue, I appreciate it.
Kelly
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.275 seconds
Donation Image