Welcome, Guest
Username: Password: Remember me

TOPIC: Relevance Equation Not Working

Relevance Equation Not Working 2 weeks 17 hours ago #110960

  • jmdsbussrv
  • jmdsbussrv's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Wow, OK, spent 4 hours on this and can't figure out why it's not working.

((25474X73X703.NAOK == "HLPN") or (25474X73X704.NAOK == "HLPN") or (25474X73X705.NAOK == "HLPN") or (25474X74X710.NAOK != "YFIN") or (25474X74X713.NAOK != "YFLN"))

Easier to read:

((25474X73X703.NAOK == "HLPN")
or (25474X73X704.NAOK == "HLPN")
or (25474X73X705.NAOK == "HLPN")
or (25474X74X710.NAOK != "YFIN")
or (25474X74X713.NAOK != "YFLN"))

For the relevance field on a group, the three "HLPN"'s are all in one group and the other 2 are in another group. Survey set to group by group.

The first three alone work.

I cannot get the second 2 to work together. They are both "not equal to" equations. They will work separate from each other, but not together. I've tried isolating each by parentheses, different combinations, etc. Nothing makes the question hide.

Any help is appreciated.
The administrator has disabled public write access.

Relevance Equation Not Working 2 weeks 16 hours ago #110961

  • jmdsbussrv
  • jmdsbussrv's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Found a workaround ....

((25474X73X703.NAOK != "HLPY") and (25474X73X704.NAOK != "HLPY") and (25474X73X705.NAOK != "HLPY") and (25474X74X710.NAOK != "YFIN") and (25474X74X713.NAOK != "YFLN"))

But it leads me to the question ...

Are we not able to combine the == and != into a single equation? Or is my syntax wrong?
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.095 seconds
Donation Image