Welcome, Guest
Username: Password: Remember me

TOPIC: Array (texts) error

Array (texts) error 7 months 3 weeks ago #105684

  • TAdams
  • TAdams's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 1
  • Karma: 0
I have a lengthy survey with many question groups. Question 1 in the survey is a screener question to determine which groups the user will receive in the survey. A majority of the groups repeat the same questions. Group #20 question 10 is an array (texts) question that is 4 rows and 3 columns. If I program this specific question with 4 rows and 3 columns the survey breaks. That is, I make selections in question one and the survey will not paginate, it only loads the introduction page again. If I edit question 10 in group 20 to only have 4 rows and 2 columns or 3 rows and 3 columns, the survey will work. Question 1 will accept my selections and paginate to question 2.
I repeat this survey on an annual basis and this is the first year I have had this problem. It has taken me weeks to uncover the exact nature of the error.

Please help. We need to begin fielding very soon.
Last Edit: 7 months 3 weeks ago by TAdams.
The administrator has disabled public write access.

Array (texts) error 7 months 2 weeks ago #105852

  • TAdams
  • TAdams's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 1
  • Karma: 0
Hello all, I have spent many hours testing my survey as well as adding and deleting questions trying to get to the root of my problem. After many hours I have discovered I am having the same problem outlined in this post back in November of 2012:
TOPIC: Clicking 'Next' button brings up 'Back button' error
www.limesurvey.org/en/forum/design-issue...n-error?limitstart=0

However, I am running LS 2.0..

Additionally, this survey is only an update of the survey I ran last year and it worked perfectly. I can't see any reason why an exact copy of the survey with updated text for 2014 would suddenly fail.

Any help would be appreciated.
The administrator has disabled public write access.

Array (texts) error 7 months 2 weeks ago #105888

  • TAdams
  • TAdams's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 1
  • Karma: 0
It seems there was a bug report on this in 2012 on the 2.0 version. It says the issue was resolved but I am having the problem now.

bugs.limesurvey.org/view.php?id=5901
The administrator has disabled public write access.

Array (texts) error 7 months 2 weeks ago #105932

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4264
  • Thank you received: 801
  • Karma: 368
Can you attach an export of the survey for us to test?

If it's sensitive you can send me a private message.


.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.092 seconds
Donation Image