Welcome, Guest
Username: Password: Remember me

TOPIC: Questions get lost after reordering

Questions get lost after reordering 9 months 1 week ago #105306

I am having a severe problem with the question reordering function.
Here is a typical scenario:
1. Set up a survey with a number of questions (for example, 75 questions in 3 groups)
2. Add a new question. By default this always seems to be added as the very last question in the
selected group.
3. Use re-ordering function to move new question to its proper position in the ordering.
This seems to go OK -- I get a message saying that the re-ordering was successful.
BUT
When I look at the list of questions in the group concerned, most of them have disappeared. I can also see by looking in the database that the questions really are missing. There are some characteristic features of this odd behaviour:
a) It is always the last questions in the group which disappear. Or, to say it in a different way,
the first few questions are not deleted.
b) The question which was moved always disappears.
c) The position at which deletion starts is NOT the position at which I attempted to insert the
question which was moved.

I am using Limesurvey 2.00+, build 131206.
The PHP version is 5.4.7.

Is there some well-known patch or workaround for this? I can't find anything in the forums.

Robin.
The administrator has disabled public write access.

Questions get lost after reordering 9 months 1 week ago #105312

  • mfaber
  • mfaber's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 85
  • Thank you received: 22
  • Karma: 4
I had trouble with sorting questions in 2.05, which was then solved by one of the developers.
See bugs.limesurvey.org/view.php?id=8467
Maybe you can update your installation? Or file a bug report...
The administrator has disabled public write access.
The following user(s) said Thank You: robin_sharp

Questions get lost after reordering 9 months 6 days ago #105353

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5426
  • Thank you received: 307
  • Karma: 252
Hi Robin,

please test if this can still be reproduced at our demo which always ruins the latest Limesurvey version. If so, please file a bug report. If not -> update.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
The following user(s) said Thank You: robin_sharp

Questions get lost after reordering 9 months 6 days ago #105356

:)
Thanks for the hint to try the Demo version.
I can see that the fault has been corrected in LS 2.05
... I was just waiting for the comfort update, but can see I need to update NOW!

Robin
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.108 seconds
Donation Image