Welcome, Guest
Username: Password: Remember me

TOPIC: Optout doesn't work correct

Optout doesn't work correct 9 months 3 weeks ago #104454

  • joost1982
  • joost1982's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 15
  • Thank you received: 1
  • Karma: 1
I created a test survey and invited myself on several e-mail accounts with the "send e-mail invitation" button.
Then I tried to "optout" on some accounts. It only worked with the link in the e-mail account where I opted out first. All the links in the other accounts I tried after that failed. (with the message that I already opted out).

Then I looked in the token table and a whole other user than the user that opted out had "optout" in his e-mail status than the user that did optout.

I tried it with several other test surveys. Everytime only one user could optout and the strangest thing is that every time (it seemed random) another user had "optout" in his e-mail status than the user who actually opted out. What is wrong here?
The administrator has disabled public write access.

Optout doesn't work correct 9 months 3 weeks ago #104457

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2958
  • Thank you received: 381
  • Karma: 124
Could it be that you made those tests all from the same computer? Could it be that the "random" user that had optout in his email status was actually the last one you tried to optout?

Never the less, the link should work for the respective email address and it shouldn't matter if you have already opted out from this computer but for another email.

It would be great if you could do some more tests so you can narrow the error down as much as possible and then write a bug report.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
The following user(s) said Thank You: DenisChenu

Optout doesn't work correct 9 months 3 weeks ago #104469

  • joost1982
  • joost1982's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 15
  • Thank you received: 1
  • Karma: 1
No the tests weren't run from the same computer. I just ran another test:
- I constructed a test survey
- added some fake respondents (manually) with a couple of different e-mail addresses owned by me (respondent 1, 2 and 3)
- invited the respondents with the send invitations button
- opted respondent 1 out from another computer (where I opened the invitation)
- checked my token table and saw that another respondent (2) was opted out and not respondent 1
- after that I added several other respondents and invited them, opened the invitations on my phone, on the computer of a colleague and on my home computer, but NONE of the extra added respondent was able to opt out. Every time I got the message "already opted out" or something.

Is this a database issue? I recently moved to another hosting provider...
The administrator has disabled public write access.

Optout doesn't work correct 9 months 3 weeks ago #104487

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6551
  • Thank you received: 869
  • Karma: 257
holch wrote:
It would be great if you could do some more tests so you can narrow the error down as much as possible and then write a bug report.
The administrator has disabled public write access.

Optout doesn't work correct 9 months 3 weeks ago #104509

  • joost1982
  • joost1982's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 15
  • Thank you received: 1
  • Karma: 1
Yes! Problem resolved: bugs.limesurvey.org/view.php?id=8656

Thanks thanks thanks!!!
The administrator has disabled public write access.
The following user(s) said Thank You: DenisChenu

Optout doesn't work correct 9 months 3 weeks ago #104603

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6551
  • Thank you received: 869
  • Karma: 257
joost1982 wrote:
Yes! Problem resolved: bugs.limesurvey.org/view.php?id=8656

Thanks thanks thanks!!!
Thanks to you to report this bug :)
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.148 seconds
Donation Image