Welcome, Guest
Username: Password: Remember me

TOPIC: Survey URL isn't a Link in Invite Email

Survey URL isn't a Link in Invite Email 6 months 1 week ago #103889

  • kripp88
  • kripp88's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
We recently just upgraded from 1.9 to 2.0, build 130802. Everything is going smooth except that we have a fair amount of users complaining that the survey url in the email the receive is not a link so they can't click it. This has happened for multiple surveys so far. We use remotecontrol 2 api to schedule most of our invites so I took a look at the code that generates the email message and can't see any obvious reason for why this would happen. The odd thing is that when they forward the message they received to us, we can clearly see that the URL is a link. Could this be something specific to certain email providers? But I'm wondering why we would have never experienced this issue in 1.9 then.

Thanks,
Kyle
The administrator has disabled public write access.

Survey URL isn't a Link in Invite Email 6 months 4 days ago #104062

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6219
  • Thank you received: 791
  • Karma: 238
Maybe the rc api have some bug here.

Can you test with the last 2.05 version (and send me an invitation to denis<AT>sondages<DOT>pro
The administrator has disabled public write access.

Survey URL isn't a Link in Invite Email 6 months 4 days ago #104083

  • kripp88
  • kripp88's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
It doesn't happen on every invite, in fact it only happens rarely. It seems to happen more frequently when we are sending out invites in large batches. We have 10 surveys that get scheduled each night and run 5 minutes apart from each other. The issue usually happens with our larger surveys where up to 700 invites will get sent out each night.
The administrator has disabled public write access.

Survey URL isn't a Link in Invite Email 6 months 4 days ago #104097

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4068
  • Thank you received: 746
  • Karma: 341
Could it be email-client related? Can you pin it down to one or more clients, like Outlook or Thunderbird?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Survey URL isn't a Link in Invite Email 6 months 4 days ago #104102

  • kripp88
  • kripp88's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
That was my initial thought, but we've seen it for Yahoo, Outlook and others so far.
The administrator has disabled public write access.

Survey URL isn't a Link in Invite Email 5 months 2 weeks ago #104875

  • kripp88
  • kripp88's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
Ok, so I think I've narrowed it down. It only happens when using the Json RPC API to send invites. It looks like some email clients such as Gmail and iMail can recognize the text as a link and will turn it into a link automatically. Yahoo and Outlook however, have issues. We are using the same template and surveys as we did in 1.9 when this wasn't an issue. Could the issue be with Remote Control API? We just finished upgrading from 1.9 to 2.0 and any other possible solutions besides upgrading to a newer version would be greatly appreciated.

Thanks,
Kyle
The administrator has disabled public write access.

Survey URL isn't a Link in Invite Email 5 months 2 weeks ago #104907

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
How do you add the URL at the email templates? Are you simply adding the raw URL there or do you use {SURVEYURL} or anything else?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Survey URL isn't a Link in Invite Email 5 months 2 weeks ago #104921

  • kripp88
  • kripp88's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
Yes, we are using {SURVEYURL} in the email template. The odd thing is that this only happens when we use the RemoteControl inviteParticipants and not when we send invites through the LS interface.
The administrator has disabled public write access.

Survey URL isn't a Link in Invite Email 5 months 2 weeks ago #104922

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5300
  • Thank you received: 291
  • Karma: 247
Really weird. Please file a bug report.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Survey URL isn't a Link in Invite Email 5 months 2 weeks ago #104926

  • kripp88
  • kripp88's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
Ok thanks, I have filed on here: bugs.limesurvey.org/view.php?id=8699
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.139 seconds
Donation Image