Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Using a plugin do not work

Using a plugin do not work 8 months 2 weeks ago #101383

  • plhostis
  • plhostis's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
Hello

I'm trying to use plugin DigitalBush Masked Input Plugin in my survey
( see section workarounds: Text input mask second method in LS web manual)
i have added the line <script type="text/javascript" src="{TEMPLATEURL}jquery.maskedinput.js" charset="utf-8"></script> in then startpage.pstpl
but when i test my survey i have an error $(...).mask is not a function... !!!
any idea ?

FireFox 17.0.4
LS 2.00+ build 130802
The administrator has disabled public write access.

Using a plugin do not work 8 months 2 weeks ago #101390

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4054
  • Thank you received: 740
  • Karma: 341
Did you make sure to add that to startpage.pstpl AFTER the {TEMPLATEJS} tag?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Using a plugin do not work 8 months 2 weeks ago #101392

  • plhostis
  • plhostis's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
yes i verified all the tag in the startpage.pstpl i followed exactly what is written in
Implementation as follows:
1.Visit digitalbush.com/projects/masked-input-plugin/, download the latest plugin script and save it as jquery.maskedinput.js in the template folder.
2.Link to the script by placing <script type="text/javascript" src="{TEMPLATEURL}jquery.maskedinput.js" charset="utf-8"></script> within the <head> tag of startpage.pstpl.
3.Turn off $filterxsshtml to allow insertion of JavaScript in the questions. (See documentation here)
4.Create the text input questions that the masks are to be applied to
5.In the source of the help section of the first question of the group that contains the masked inputs, add the following code. (See How to use script here)





<script type="text/javascript" charset="utf-8">
$(document).ready(function($) {
$("#answer55431X1X5").mask("999-99-9999",{ placeholder:"#" });
});
</script>
The administrator has disabled public write access.

Using a plugin do not work 8 months 2 weeks ago #101403

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4054
  • Thank you received: 740
  • Karma: 341
Can you activate a test survey?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Using a plugin do not work 8 months 2 weeks ago #101410

  • plhostis
  • plhostis's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
yes i tried with a inactive and active survey , it is the same. :evil:
The administrator has disabled public write access.

Using a plugin do not work 8 months 2 weeks ago #101416

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2549
  • Thank you received: 285
  • Karma: 102
What Tpartner means, is there a way that you can provide a link to a test survey, where we can have a look at it.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Using a plugin do not work 8 months 2 weeks ago #101439

  • plhostis
  • plhostis's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
unfortunately no we are not over Internet.
It seems to erase the line i have added...

<script type="text/javascript" src="{TEMPLATEURL}jquery.meiomask.js" charset="utf-8"></script> within the <head> tag of startpage.pstpl.

just after tag {TEMPLATEJS} , i don't know why. i tried with IE 9 and Firefox 17.0.4
The administrator has disabled public write access.

Using a plugin do not work 8 months 2 weeks ago #101465

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2549
  • Thank you received: 285
  • Karma: 102
Did you follow the recommendations of the manual on how to use Javascript in Limesurvey? is the XSS filter switched off?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Using a plugin do not work 8 months 2 weeks ago #101487

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4054
  • Thank you received: 740
  • Karma: 341
Hmm, truly odd.

If you can't publish a survey, can you attach exports of the template and a sample survey?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Using a plugin do not work 8 months 4 days ago #101729

  • plhostis
  • plhostis's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 20
  • Karma: 0
Hello

ok i send you an survey export .lss
Attachments:
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.139 seconds
Donation Image