Welcome, Guest
Username: Password: Remember me

TOPIC: Hidden questions appear when you tab to them even if conditions weren't met!!!!!

Hidden questions appear when you tab to them even if conditions weren't met!!!!! 5 months 4 weeks ago #100851

  • w0928
  • w0928's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 26
  • Thank you received: 3
  • Karma: 1
I have questions that are hidden that are set to be shown when a preceding question has a certain answer. If I just click anywhere on the page and press the tab key enough times the hidden questions are shown. This happens when the question that the hidden questions depend on have focus.

For example, you have 4 questions. Question 4 is shown when the user answers "no" to question 3. Click on any part of question 1 then begin to hit the tab key. You will see the focus shift through the various inputs on questions 1 then 2. When you get to question 3 and start to tab through the inputs question 4 will appear.

How do we prevent this from happening?
The administrator has disabled public write access.

Hidden questions appear when you tab to them even if conditions weren't met!!!!! 5 months 3 weeks ago #100898

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3813
  • Thank you received: 683
  • Karma: 327
That may be a bug. Please file a bug report and...
1. Give as much information as possible.
2. Provide step-by-step instructions how to reproduce the problem.
3. Provide screenshots and a sample survey.
4. Post the link to the bug here so we can follow the progress.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Hidden questions appear when you tab to them even if conditions weren't met!!!!! 5 months 3 weeks ago #100921

  • w0928
  • w0928's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 26
  • Thank you received: 3
  • Karma: 1
I will submit a bug report. In the meantime I wanted to provide a bit more info here. It seems to only happen when the question that the hidden question depends on (question 3 in my scenario above) is a radio button type of question. Also, the 'no answer' option in the general settings is turned off. It happens when none of the radio buttons have been checked.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.132 seconds
Donation Image