Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Array_filter in Ranking has stopped working

Array_filter in Ranking has stopped working 7 months 3 weeks ago #99485

  • carmcomp
  • carmcomp's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Within a question group, there is a Ranking question type that has an array_filter based on 2 previous questions, one multiple choice and one array(texts). The filter was working perfectly when these were the only questions in the group. I have since added additional questions to the group and re-sequenced the questions and now the filter is no longer working. Is there a special consideration that I'm missing? Version 2.00 plus (build130317). Thank you.
The administrator has disabled public write access.

Array_filter in Ranking has stopped working 7 months 2 weeks ago #99533

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3813
  • Thank you received: 683
  • Karma: 328
Are the filtering questions placed before the filtered one. Are all question codes unique?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Array_filter in Ranking has stopped working 7 months 2 weeks ago #99583

  • carmcomp
  • carmcomp's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Thank you for your quick response. I was able to resolve the issue. I removed all the questions from the group that I had added since the filter stopped working. The filter was again working perfectly. Then I one-by-one added the questions back into the group until I found the one that caused it to break. It turned out that the question that caused it to break had a bad validation equation. This question was unrelated to the question with the array_filter in place. Once I removed the validation equation, everything worked well. I'm not sure I understand why that would have caused the problem and if someone has time, I would like to have an explanation so as to avoid future occurences. Thanks again.
The administrator has disabled public write access.

Array_filter in Ranking has stopped working 7 months 2 weeks ago #99643

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3813
  • Thank you received: 683
  • Karma: 328
The bad validation equation was probably throwing a fatal JavaScript error preventing any subsequent script (the filtering) on the page from running.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Array_filter in Ranking has stopped working 6 months 5 days ago #100759

  • carmcomp
  • carmcomp's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
We are continuing to have issues with the array_filter on the ranking question. We have added relevance equations to the two questions being used in the filter as well as the ranking question. When the relevance is in place, the array_filter no longer works. If we remove the relevance, the array_filter does its job populates the ranking as expected. Are there any suggested fixes or workarounds to this problem?

Thank you.
The administrator has disabled public write access.

Array_filter in Ranking has stopped working 6 months 5 days ago #100760

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3813
  • Thank you received: 683
  • Karma: 328
Can you attach a test survey?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Array_filter in Ranking has stopped working 6 months 5 days ago #100762

  • carmcomp
  • carmcomp's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
The group the question is in is MARC Records. The question code of the ranking question is MR15_3, being filtered with MR15_2 and MR15_A.
The administrator has disabled public write access.

Array_filter in Ranking has stopped working 6 months 5 days ago #100766

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3813
  • Thank you received: 683
  • Karma: 328
Can you attach a test survey?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Array_filter in Ranking has stopped working 6 months 5 days ago #100767

  • carmcomp
  • carmcomp's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Sorry - I attempted to attach the test survey to my last message, but it was too large. I exported the group and attached it here. Hopefully that will be sufficient?
Attachments:
The administrator has disabled public write access.

Array_filter in Ranking has stopped working 6 months 5 days ago #100774

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3813
  • Thank you received: 683
  • Karma: 328
Hmm...I am not able to import that group into my 2.0installation or at the limesurvey.org demo installation.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.114 seconds
Donation Image