Welcome, Guest
Username: Password: Remember me

TOPIC: Hiding Questions

Hiding Questions 1 year 1 month ago #99067

  • TarkiB
  • TarkiB's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Hi there,

I've got an autocomplete script set up, so that a user can fill in an ID and an additional 4 short text fields are automatically filled in. I want to hide these 4 short text fields. However, the text that was placed in them will be used in an Equation Type question later on that page.

Selecting 'Always Hide This Question' prevents the field from getting auto-filled. Is there a way to avoid this?

I tried using css to hide the questions. For example, for one question the ID is AQ1, the SGQA identifier is 929648X20X144. I've put the following at the end of template.css
#question929648X20X144 {
	display: none;
}

However the question still appears. What am I doing wrong here?

Cheers!
The administrator has disabled public write access.

Hiding Questions 1 year 1 month ago #99072

  • jelo
  • jelo's Avatar
  • OFFLINE
  • Platinum Lime
  • Posts: 467
  • Thank you received: 52
  • Karma: 16
Since hiding the question is working without using workarounds i might be wrong, but try
#answerQQ {
	display: none;
}

and use the QuestionID, not the complete SGQA.
manual.limesurvey.org/SGQA_identifier

Attach a part of your survey here if you need more help.

I would still try to use the hide question feature of limesurvey.
If you don't hide your questions the equation type questions are working fine? And if you hide then the equation fails? Would like to see that survey.

Please post your Limesurvey version/build and PHP version. Perhaps you just use a buggy version.
The administrator has disabled public write access.

Hiding Questions 1 year 1 month ago #99110

  • TarkiB
  • TarkiB's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Hmm, I tried:
#answerAQ1 {
	display: none;
}

and:
#questionAQ1 {
	display: none;
}

Had no luck with either of these unfortunately. It seems that if I hide the question, the field doesn't get autofilled. The equation type question, which pulls the answer from the field, shows as empty when the field has been hidden. All of these questions are on the same page, if that's relevant.

I'm running Version 2.00+ Build 130406, on Server 2008, with Apache 2.2.21 and PHP 5.3.8.

Thanks
Last Edit: 1 year 1 month ago by TarkiB.
The administrator has disabled public write access.

Hiding Questions 1 year 1 month ago #99163

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6334
  • Thank you received: 818
  • Karma: 243
Try #answer929648X20X144AQ1

And quickest way is to use firebug ....

Denis
The administrator has disabled public write access.

Hiding Questions 1 year 3 weeks ago #99301

  • cberghoff
  • cberghoff's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
Hi everyone,

I'm having this exact same problem. When I use the always hide this question option,JavaScript functions don't run and values are not stored. Also, display: none in the stylesheet isn't taking care of the problem.

Based upon the experience of the repliers in this thread, I take it that this is unexpected behavior. It seems that having the option to always hide an item, that then becomes useless, offers no real benefit. Are we looking at a bug??

Happy to provide a copy of a survey if it helps. I'm running build 130802 at HostGator on a server running PHP 5.2.17
Chris
The administrator has disabled public write access.

Hiding Questions 9 months 4 weeks ago #101796

  • dweisser
  • dweisser's Avatar
  • OFFLINE
  • Bronze Donor
  • Posts: 204
  • Thank you received: 5
  • Karma: 5
Not sure if it helps or not, or if its too late, but I too was having this same problem. I came across a post that indicated that in order for values to be stored, the hidden question has to appear on a subsequent page.

So I was using Expression Manager to indicate if Visible Answer 1 = 1, then Hidden Answer 2 = A. It was maddening that I couldn't get Hidden Answer2 to display in an Email template. When I moved the Hidden Question to a later page, all fell into place.

Good luck.
David
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.128 seconds
Donation Image