Welcome, Guest
Username: Password: Remember me

TOPIC: Runtime session cookie and problem with Conditional questions not showing

Runtime session cookie and problem with Conditional questions not showing 1 year 1 month ago #96923

  • joss
  • joss's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 16
  • Karma: 0
In my demo survey I have a lot of conditional questions where you select an answer and sub-questions occur.

When you run the survey for the first time in a browser everything is wonderful. If you refresh or visit the survey later the next days all conditional questions are not shown, so the survey is wrong.

While searching for the solution, I found out that when I erase the runtime session cookie from the browser, everything works fine!

What exactly is this cookie? "ls55732999468247977246-runtime-28836"
and how can I disable it from loading?

Thanks
The administrator has disabled public write access.

Runtime session cookie and problem with Conditional questions not showing 1 year 1 month ago #96944

  • joss
  • joss's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 16
  • Karma: 0
After a lot of beta testing I came to the conclusion that if I erase the creation of the cookie from index.php the problem is not solved. But if I erase it after the creation everything is ok.

It occurs in both Yes or No options at General Settings -> Set cookie to prevent repeated participation, which I think is the start of the problem.

Now MAYBE THE SOLUTION:
When I click "Exit and clear survey" and start again everything works. So trying to go directly to the url h++p://survey/index.php?sid=28836&newtest=Y seems to solve the problem.
The administrator has disabled public write access.

Runtime session cookie and problem with Conditional questions not showing 1 year 1 month ago #96952

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6240
  • Thank you received: 794
  • Karma: 238
Hello,
When you run the survey for the first time in a browser everything is wonderful. If you refresh or visit the survey later the next days all conditional questions are not shown, so the survey is wrong.
The old answer of the survey is still here ?

If yes : can you provide a step by step instruction, and a lss file on the bug tracker ?
www.limesurvey.org/community-services/bug-tracker

Denis
The administrator has disabled public write access.

Runtime session cookie and problem with Conditional questions not showing 1 year 1 month ago #97061

  • joss
  • joss's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 16
  • Karma: 0
No, the previous answers are not shown
Any idea why this is happening?

Thanks
The administrator has disabled public write access.

Runtime session cookie and problem with Conditional questions not showing 5 months 3 weeks ago #104834

  • joss
  • joss's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 16
  • Karma: 0
Found the answer, I had

"Set cookie to prevent repeated participation?" to YES

when I changed to NO the problem stopped
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.124 seconds
Donation Image