Welcome, Guest
Username: Password: Remember me

TOPIC: trying to use a <form>, but tags disappearing

trying to use a <form>, but tags disappearing 1 year 3 months ago #94432

  • jenllip
  • jenllip's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
I am trying to insert a <form> button which takes prior answers and feeds them off to an external site, but it doesn't seem to be working. The button shows up appropriately in the sample page, and when I inspect the code of the sample everything is there (including the correct data pull), but the <form> and </form> lines are completely missing.

Edit to add: "Filter HTML for XSS" is set to no.

I feel like I'm missing something tiny, but I can't figure out what. Any thoughts?
<form action="EXTERNALSITE" method="post" target="_blank"><!-- Why does this line disappear? -->
<input name="INPUT1" type="hidden" value="VALUE1" />
<input name="INPUT2" type="hidden" value="_xclick" />
<input name="INPUT3" type="hidden" value="VALUE2" />
<input name="INPUT4" type="hidden" value="
<!-- Seems to need JS to strip Span tags from around the EM math output -->
    <script language=javascript>
      var txt='{HiddenTotal - HiddenOverage}';
          document.write(txt);
    </script>
" />
<input name="INPUT5" type="hidden" value="VALUE5" />
<input alt="IMAGE ALT TEXT" border="0" name="submit" src="BUTTON IMAGE HOSTED EXTERNALLY" type="image" />
</form><!-- Why does this closing tag disappear? -->
Last Edit: 1 year 3 months ago by jenllip.
The administrator has disabled public write access.

trying to use a <form>, but tags disappearing 1 year 3 months ago #94441

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6205
  • Thank you received: 787
  • Karma: 238
Hello,

Think it's more easy t use directly jquery.post.

Denis
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.105 seconds
Donation Image