Welcome, Guest
Username: Password: Remember me

TOPIC: Unable to edit Question Groups or Questions

Unable to edit Question Groups or Questions 1 year 7 months ago #94101

  • itfixt
  • itfixt's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Karma: 0
Apologies if this is posted in the wrong place but I don't think this is classed a a bug... yet.
LimeSurvey Version 2.00+ Build 130317
Ubuntu Linux 12.04.1
Apache 2.2.22
PHP Version 5.3.10-1ubuntu3.4
MySQL version 5.5.28

I have two surveys under the same username. One works perfectly. The other suddenly stopped allowing edits to Question Groups and Questions. I.e., if you click on the "Edit current question group" having selected one in the drop-down, the page refreshes but the area below the navigation bars stays empty. Examination of the HTML shows that the required data is missing, rather than just hidden. The behaviour with individual questions is identical. None of the following have made any difference:
  • Changing the admin style.
  • Cleared the browser cache and cookies after logging out, then logged back in.
  • Exported the survey then re-imported it again into a new, empty survey.
  • Exported an individual question then re-imported it again into a new, empty survey.

Exporting a Question Group and re-importing it into an empty survey restored the ability to edit the Group - but not the individual questions.
Having clicked the button to edit a Question, if I then delete the session cookie and refresh the page I have to log back in again, of course, and then the page appears correctly, with the editable question!!

I have tried this with both the latest LS build and the previous one. I even did a clean install of the previous build and imported the survey into that with precisely the same results.

I should add that this was all working perfectly and suddenly stopped for no apparent reason. Any suggestions (other than re-inputting the whole survey!) gratefully received.
This space accidentally left blank
The administrator has disabled public write access.

Unable to edit Question Groups or Questions 1 year 7 months ago #94104

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6429
  • Thank you received: 840
  • Karma: 249
Hello,

Please set debug=2 in config.php to have more information.

Denis
The administrator has disabled public write access.

Unable to edit Question Groups or Questions 1 year 7 months ago #94107

  • itfixt
  • itfixt's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Karma: 0
Thanks Denis. I had seen that debug setting in the config & then forgotten all about it :blush:

I tried it and when I tried to display the survey (choosing it from the drop-down), I get:
Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 7589464 bytes) in /var/www/clients/client2/web70/web/ls2/application/helpers/expressions/em_manager_helper.php on line 6045

I don't get that on the other survey.

Cheers
Dave
This space accidentally left blank
The administrator has disabled public write access.

Unable to edit Question Groups or Questions 1 year 6 months ago #94112

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2839
  • Thank you received: 356
  • Karma: 123
Well, seems like your questionnaire has reached a limit somewhere. Could it be that it is a very big questionnaire and makes a lot of use of the Expression Manager?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Unable to edit Question Groups or Questions 1 year 6 months ago #94113

  • itfixt
  • itfixt's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Karma: 0
holch wrote:
Well, seems like your questionnaire has reached a limit somewhere. Could it be that it is a very big questionnaire and makes a lot of use of the Expression Manager?

It's not that big - some 30 question groups, mostly each containing around 6 questions. And yet the Questions table in the DB has 3101 rows for the relevant survey.

Cheers,
Dave
This space accidentally left blank
The administrator has disabled public write access.

Unable to edit Question Groups or Questions 1 year 6 months ago #94114

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6429
  • Thank you received: 840
  • Karma: 249
Did you have a lot of condition ?
Did you use array_filter and array_filter_exclusion a lot ?

6 question: but with or without sub question ?
The administrator has disabled public write access.

Unable to edit Question Groups or Questions 1 year 6 months ago #94118

  • itfixt
  • itfixt's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Karma: 0
DenisChenu wrote:
Did you have a lot of condition ?
No.
DenisChenu wrote:
Did you use array_filter and array_filter_exclusion a lot ?
No.
DenisChenu wrote:
6 question: but with or without sub question ?
A few.

Structure is:

- Number of questions/groups: 154/22
- Two questions in each group, bar the first group, have 1 sub-question.
- Each group has several more questions with no sub-questions.
This space accidentally left blank
Last Edit: 1 year 6 months ago by itfixt. Reason: Left a bit out :(
The administrator has disabled public write access.

Unable to edit Question Groups or Questions 1 year 6 months ago #94120

  • itfixt
  • itfixt's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 14
  • Karma: 0
I just increased the max memory in php.ini to 384M & it all works now - but that 's obviously still not satisfactory behaviour :} Should I raise a bug report for this?
This space accidentally left blank
The administrator has disabled public write access.

Unable to edit Question Groups or Questions 1 year 6 months ago #94121

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2839
  • Thank you received: 356
  • Karma: 123
What is strange is that you see to have 128MB (134217728 bytes) of memory, but 7-8MB are already too much. I am not an expert here but this sounds like there is something blocking a lot of the memory.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Unable to edit Question Groups or Questions 1 year 6 months ago #94122

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2839
  • Thank you received: 356
  • Karma: 123
I am not sure if the problem actually is limesurvey or something else on your server. 7-8MB of memory usage for a survey sound a lot to me, but then it is not a small survey. But I don't have any data for comparison.

What is strange is that basically 120MB of your allocated memory was already used by something else. What else is running on your webserver?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.175 seconds
Donation Image