Welcome, Guest
Username: Password: Remember me

TOPIC: default template, 2 row multi-choice question and Internet Explorer

default template, 2 row multi-choice question and Internet Explorer 1 year 1 month ago #93310

  • pweldon
  • pweldon's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Hi. I'm using Limesurvey 2.0 - and basing my survey on the 'default' template.

I have a question that uses the 'multiple choice' question type and I have set 'display columns' to 2

Looks fine in Firefox but in IE the boxes are indented and the text is underneath the box.

This doesn't happen with radio buttons when display columns is 2 in IE.

I've attached a screen shot from IE. Anyone know how to resolve this?
Attachments:
The administrator has disabled public write access.

default template, 2 row multi-choice question and Internet Explorer 1 year 1 month ago #93469

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3837
  • Thank you received: 688
  • Karma: 330
What version of IE?

Can you activate a sample survey for us to test?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

default template, 2 row multi-choice question and Internet Explorer 1 year 1 month ago #93566

  • pweldon
  • pweldon's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
IE 8.0.6001

here's a sample survey:

sias.acer.edu.au/index.php?r=survey/index/sid/535482/lang/en

Thanks
Paul
The administrator has disabled public write access.

default template, 2 row multi-choice question and Internet Explorer 1 year 1 month ago #93658

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3837
  • Thank you received: 688
  • Karma: 330
Unfortunately, I can't see what's causing the misalignment.

This is what I see in IE8 - Win-7:

Capture_2013-03-13.JPG
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

default template, 2 row multi-choice question and Internet Explorer 1 year 1 month ago #93691

  • pweldon
  • pweldon's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
I passed this to our IT guys and got this response:

"I think the issue lies in the version of IE8, this is an early build of IE8 which does not seem to support the css style that is being used, while even just later versions of IE8 seem to."

that is, this build of IE 8 is the current latest for XP, Vista, and Windows Server 2008 R2 (see support.microsoft.com/kb/969393) - IE 7 and earlier and IE 8 for Win7 etc is fine.

Our guy found a fix that looks like the attachment - if you're interested I can ask him to post it...
Attachments:
The administrator has disabled public write access.

default template, 2 row multi-choice question and Internet Explorer 1 year 1 month ago #93709

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 5869
  • Thank you received: 719
  • Karma: 223
pweldon wrote:
Our guy found a fix that looks like the attachment - if you're interested I can ask him to post it...
Great,

Please fill a bug report with patch.

Denis
PS: Tony: have an XP installation with IEtester (IE6/7/8) i can take the bug.
The administrator has disabled public write access.

default template, 2 row multi-choice question and Internet Explorer 1 year 1 month ago #94026

  • pweldon
  • pweldon's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
I'll post to the bug tracker, but as the fix is simple I'll put it here too. It seems to affects the latest version of IE for XP (8). The fix is:

The code was:
display: inline-block;
The code I used was a known Internet Explorer hack:
display: inline-block;
display: inline\9;

Internet Explorer will be the only browser that reads that second line which will override the first line. I just replaced all instances where that first line of code exists with the two lines of code, inside the template.css file.
The administrator has disabled public write access.

default template, 2 row multi-choice question and Internet Explorer 1 year 1 month ago #94037

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 5869
  • Thank you received: 719
  • Karma: 223
Hello,

In general i use:
display: inline;display: inline-block;

Navigator who don't understand inline-block don't read second instruction.

Don't know what is the best :)
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.114 seconds
Donation Image