Welcome, Guest
Username: Password: Remember me

TOPIC: "Uses left" for tokens being ignored

"Uses left" for tokens being ignored 1 year 9 months ago #87071

  • Joshua
  • Joshua's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hello everyone,

I am facing a somewhat strange behavior of LimeSurvey (Version 2.00+ Build 121017) in my first self-made survey and am not entirely sure whether it's me or the software. Maybe you can tell!

Here's the situation: I have created a rather simple, closed, anonymous survey and issued a token with an "uses left" value of 1. Invitation mails are being sent out via e-mail just as desired and I can easily complete my survey. As soon as this has been done, the token's "uses left" value goes down to 0 and "completed" is set to "Y" - beautiful.

Now here the trouble starts: I can simply click on the token link inside my e-mail again and do the survey once again! After repeated completen, the "uses left" go down to "-1" (oups!) and "completed" stays at "Y". I also receive an additional reply record in my data.

I would instead expect the user to be able to modify his old reply, as set up in the survey settings.

Is this the correct behavior of the system? I have browsed multiple threads in this community but couldn't find anybody reporting the same issue, so I still assume it's some kind of misconfiguration that you could hint me at.

Thanks a lot!

Joshua
Last Edit: 1 year 9 months ago by Joshua.
The administrator has disabled public write access.

Re: "Uses left" for tokens being ignored 1 year 9 months ago #87106

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6222
  • Thank you received: 791
  • Karma: 238
Strange think, can you upload the lss file to see the survey settings ?

(Not attented behaviour)
The administrator has disabled public write access.

Re: "Uses left" for tokens being ignored 1 year 9 months ago #87229

  • Joshua
  • Joshua's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Dear Denis,

Thanks for your reply and sorry for keeping you waiting.

I just found out that this behavior is obviously linked to the "Allow editing responses after completion?" preference on the "Tokens" tab. After disabling it, the survey works perfectly. Unfortunately, I cannot publish the lss file due to some confidential content in the survey, but in case somebody is able to reproduce this effect, maybe it's worth filing a bug report.

Best regards

Joshua
The administrator has disabled public write access.

Re: "Uses left" for tokens being ignored 1 year 9 months ago #87230

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6222
  • Thank you received: 791
  • Karma: 238
Joshua wrote:
I just found out that this behavior is obviously linked to the "Allow editing responses after completion?" preference on the "Tokens" tab.... it's worth filing a bug report.
No,

It's an atended behaviour. If you alllow to edit response, user can came back to the suvey.

Denis
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.125 seconds
Donation Image