Welcome, Guest
Username: Password: Remember me

TOPIC: Security Question Answer always incorrect

Security Question Answer always incorrect 1 year 7 months ago #85655

  • JonM
  • JonM's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hi,

I have been trying to set up a survey using version 1.92 but it is always telling me that my security code is incorrect when I try to save an unfinished survey.

I have checked for this issue online and saw that the suhosin and mod_security extensions can cause problems that make this happen but I have checked and these are not installed on the server our survey is on but cannot find any other mention of other possible solutions to this problem.
Unfortunately after having turned debug to 1 this is no error information for this for me to think there is a problem and it does not allow me to create my own debug output so I cannot really see what is happening.

Is there anyway to turn the security code check off?
The administrator has disabled public write access.

Re: Security Question Answer always incorrect 1 year 7 months ago #85669

  • Ben_V
  • Ben_V's Avatar
  • OFFLINE
  • Platinum Lime
  • Posts: 937
  • Thank you received: 194
  • Karma: 62
I've already seen this problem (with LS older version)... when trying to embed a survey using iframe (different domains)...
In fact the verification of the security question was ok with safari but not with ie or ff !
In this case the failure was evidently due to a client-side cross-domain security.
That's all I can say...

Ben/
Benoît

goo.gl/Bw5iM => Recherche GG dans le forum français (remplacer "exemple" dans la barre de recherche)
goo.gl/WX8PH => GG search for english forum (Replace "example" in the search bar)
goo.gl/IxiGu => Búsqueda en el foro en español (Cambiar "ejemplo" en la barra de...
Last Edit: 1 year 7 months ago by Ben_V.
The administrator has disabled public write access.

Re: Security Question Answer always incorrect 1 year 7 months ago #85672

  • JonM
  • JonM's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
It is not being used like that to the best of my knowledge from what I have seen but thanks for the insight.
Seemed to have narrowed down the problem anyway, the session variable 'secanswer' set in the verification php file is set to a session variable to be checked by the save php file but it is not actually being set or the session variable is being killed before it is passed so it cannot check the given answer against the correct one at the moment.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.093 seconds
Donation Image