Welcome, Guest
Username: Password: Remember me

TOPIC: Edit index.php page

Edit index.php page 2 years 4 months ago #80750

  • IoSmith
  • IoSmith's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 28
  • Karma: 0
Hello all.
I would like to edit the page where all publicy listed surveys are available and insert my logo.

Moreover, i would like to change the favicon. I tried the obvious to replace the "favicon.ico" file in \limesurvey\admin with no results.
Attachments:
Last Edit: 2 years 4 months ago by IoSmith.
The administrator has disabled public write access.

Re: Edit index.php page 2 years 4 months ago #80763

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4206
  • Thank you received: 790
  • Karma: 360
1) The survey-list page can be modified using the template editor. Copy your desired template and edit the copy.

2) Replace the favicon in the template (and bear in mind that some browsers "remember" favicons for a long time so test for changes in another browser).
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: Edit index.php page 2 years 4 months ago #80771

  • DenisChenu
  • DenisChenu's Avatar
  • NOW ONLINE
  • Moderator Lime
  • Posts: 6362
  • Thank you received: 826
  • Karma: 245
tpartner wrote:
1) The survey-list page can be modified using the template editor. Copy your desired template and edit the copy.
And choose your template in general settings :)

Denis
The administrator has disabled public write access.

Re: Edit index.php page 2 years 4 months ago #80786

  • IoSmith
  • IoSmith's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 28
  • Karma: 0
Thank you both. I had already done the proposed changes.
I noticed that although i use a copy_of_citronade template in my survey, the survey-list page (limesurvey/index.php) uses the default (you can see it in the attachment in previous message).
So i had to change it: Global Settings->General->Default Template->set the copy_of_citronade.
Last Edit: 2 years 4 months ago by IoSmith. Reason: solved
The administrator has disabled public write access.

Re: Edit index.php page 2 years 4 months ago #80787

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4206
  • Thank you received: 790
  • Karma: 360
That is not a bug, it is expected behaviour.

There are two settings for templates, one for the survey and one for the site.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: Edit index.php page 2 years 4 months ago #80788

  • IoSmith
  • IoSmith's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 28
  • Karma: 0
tpartner wrote:
That is not a bug, it is expected behaviour.

There are two settings for templates, one for the survey and one for the site.

You are right! I've changed my message...
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.113 seconds
Donation Image