Welcome, Guest
Username: Password: Remember me

TOPIC: Exclusive options for Multiple choice not working?

Re: Exclusive options for Multiple choice not working? 2 years 4 months ago #78591

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6276
  • Thank you received: 801
  • Karma: 241
holch wrote:
Is there a way to send you the file via email or something?
You can put the file in the bug report with a private View Status The only dev's see it.
(Tom, Carsten, Mazi ....)

Denis
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 4 months ago #78596

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2640
  • Thank you received: 313
  • Karma: 115
Seems like the problem was with conditions / relevance for this question. It didn't work in the per question preview, but it worked in the per group preview, as there was some condition applied to this question.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 4 months ago #78620

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 294
  • Karma: 249
TMSWhite wrote:
There was a standard set of EM-related CSS added to to all templates.
Tom, is there a related bug ticket for this or do you have a build number for me when this was added?
Can you write 1-2 sentences why adding that CSS was necessary for EM to work properly?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 4 months ago #78684

  • TMSWhite
  • TMSWhite's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 759
  • Thank you received: 82
  • Karma: 36
Mazi-

This isn't a bug per say, but reflects how the question preview works.

Question level relevance is disabled for question preview. Otherwise, if the question was not relevant, you wouldn't be able to preview it.

However, it is not possible to the sub-question-level relevance from array filter. So, unless you preview questions upon which the current question depends, the question-level preview may seem odd.

The simplest solution is to use group level preview instead of question-level preview to truly see how the question should behave.

This also doesn't relate to the EM CSS - that affects Citronade, but not this specific issue. Those EM-specific CSS are used to (a) extract the dynamic expression results, and (b) implement the dynamic validation (changes of color coding and dynamic display of appropriate messages).
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 4 months ago #78717

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 294
  • Karma: 249
Thanks for the information, Tom.

Could you post the additional CSS here for reference so users could simply add it to their template if they are updating from an older Limesurvey version whichnis missing this?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.138 seconds
Donation Image