Welcome, Guest
Username: Password: Remember me

TOPIC: Exclusive options for Multiple choice not working?

Exclusive options for Multiple choice not working? 2 years 3 months ago #78545

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2557
  • Thank you received: 290
  • Karma: 105
I am setting up a survey where I would need the exclusive option quite a few times, but it seems not to work. Usually it should unmark any other option chosen, when one of the exclusive option is marked, correct?

Latest 1.92 installed on XAMPP on local machine.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Last Edit: 2 years 3 months ago by holch.
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 3 months ago #78547

  • TMSWhite
  • TMSWhite's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 759
  • Thank you received: 82
  • Karma: 36
The exclusive option currently works differently in 1.92 to support proper cascading. Rather than disabling the other checkboxes, it flags them as irrelevant so they become invisible. The advantage of this is that if you accidentally click the exclusive option and want to change your mind, you don't lose the values of anything else entered on that question. The disadvantage is that some users might get confused by the fact that the other questions disappear (but that is a training issue). There is a proposal to have exclusive option disable the other questions instead of hide them, but that would require a significant refactoring of EM, so it is on hold.

See this example survey.
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 3 months ago #78551

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2557
  • Thank you received: 290
  • Karma: 105
Hmmm, mine do not disappear (using Chrome).
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 3 months ago #78553

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6219
  • Thank you received: 791
  • Karma: 238
Hello Tom,

Maby some idea, to have less refactoring.

Don't disable inout, but hide them.

ACtual issue:
('#java').hide();

New issue:
('#java input').hide();

What do you mean of that ?

PS: holch : clean the cache ?
Last Edit: 2 years 3 months ago by DenisChenu.
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 3 months ago #78554

  • TMSWhite
  • TMSWhite's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 759
  • Thank you received: 82
  • Karma: 36
Please try using the default template. It works for me in Chrome, Firefox, and IE.
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 3 months ago #78557

  • TMSWhite
  • TMSWhite's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 759
  • Thank you received: 82
  • Karma: 36
Denis-

Exclusive option does accurately hide questions already (using relevance criteria). Refactoring would be needed if we wanted to disable them but not hide them. I tried a simple change of having relevance always disable questions instead of hide them, but that looks awful (e.g. array-filtered rows would still appear, but be disabled). So, disabling questions for exclusive option would require pulling it out of the internal relevance criteria and create a different set of logic for it.
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 3 months ago #78559

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2557
  • Thank you received: 290
  • Karma: 105
Or does this not work in the preview?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 3 months ago #78561

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2557
  • Thank you received: 290
  • Karma: 105
Just made a quick test survey and it doesn't show in the preview! But once the survey is activated it seems to work.

I didn't test it before, because the questionnaire is extremly long and those questions come fairly at the end.

I think this should show in the preview. As far as I remember it did before.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Last Edit: 2 years 3 months ago by holch.
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 3 months ago #78562

  • TMSWhite
  • TMSWhite's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 759
  • Thank you received: 82
  • Karma: 36
Survey,group, and question-level previews all work for me. Did you check the survey logic file to confirm you are using a valid exclusive option? Try loading the sample survey to see if you have trouble with it too.
Last Edit: 2 years 3 months ago by TMSWhite.
The administrator has disabled public write access.

Re: Exclusive options for Multiple choice not working? 2 years 3 months ago #78565

  • holch
  • holch's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 2557
  • Thank you received: 290
  • Karma: 105
Ok, Denis, this goes to you: doesn't work in Citronade... ;-)

Default works fine. This is a real pitty, because the default theme is horrible. We really need to make sure that these things work well in most templates. I am not sure what is breaking those things. We need a clean simple template with nece code that just works and where you just need to include a logo and change colors and stuff in CSS (which should have no impact at all on those kind of things, right?).

So I guess I will have to use the default theme for now then.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.141 seconds
Donation Image