Welcome, Guest
Username: Password: Remember me

TOPIC: Tokens and backwards slashes

Tokens and backwards slashes 2 years 5 months ago #76927

Okay, I've searched for an answer and I've found some answers for example I've changed the permissions on directories but I still can get this to work.

I'm stuck! I'm trying to upload a file so I can use tokens and I keep getting this error Upload file not found. Check your permissions and path (D:\****\*****\limesurvey\tmp/testList.csv) for the upload directory. I've been in and changed my file permissions, but it has made no difference. Any suggestions? I'm running Version 1.91+ Build 12358. Thanks in advance!
The administrator has disabled public write access.

Aw: Tokens and backwards slashes 2 years 5 months ago #76964

  • MPIDR
  • MPIDR's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 17
  • Karma: 0
Which server OS are you using?
The administrator has disabled public write access.

Re: Aw: Tokens and backwards slashes 2 years 5 months ago #77024

I'm using xp and windows 7, but the limesurvey installation is on a remote Microsoft Windows Server OS.
The administrator has disabled public write access.

Re: Aw: Tokens and backwards slashes 2 years 5 months ago #77036

  • MPIDR
  • MPIDR's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 17
  • Karma: 0
The PHP installation on Windows is somehow strange. PHP first copies files to its own temporary folder before moving them to the LimeSurvey tmp folder.

You need to create a temp folder for PHP and allow your IIS anonymous user write access. On Windows 2008 R2, this is most likely a Windows group called IIS_IUSRS.

Open the php.ini and search for upload_tmp_dir, session.save_path and error_log. Change the settings to the new temp folder.

Regards
MPIDR
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.111 seconds
Donation Image