Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Setting up quota's with hidden question filled by prefilled URL answer

Re: Setting up quota's with hidden question filled by prefilled URL answer 2 years 8 months ago #74386

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5348
  • Thank you received: 298
  • Karma: 250
So once you got that working smoothly it would be nice if you posted your complete solution with some comments here so others can benefit from your findings as well.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Setting up quota's with hidden question filled by prefilled URL answer 2 years 8 months ago #74394

  • dspaan
  • dspaan's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 68
  • Karma: 0
You mean the VICIdial part?
The administrator has disabled public write access.

Re: Setting up quota's with hidden question filled by prefilled URL answer 2 years 8 months ago #74441

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5348
  • Thank you received: 298
  • Karma: 250
The "Setting up quota's with hidden question filled by prefilled URL answer" part.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Setting up quota's with hidden question filled by prefilled URL answer 2 years 8 months ago #74465

  • dspaan
  • dspaan's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 68
  • Karma: 0
Like i said, didn't have time anymore to go deeper and get that working so i changed the answer to be filled out by the agent.

But if i we get another project that needs this i will give it another shot and post my findings here.
The administrator has disabled public write access.

Re: Setting up quota's with hidden question filled by prefilled URL answer 1 year 5 months ago #96311

  • ViliLe
  • ViliLe's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
Mazi wrote:
You can change the "always hide this question" setting even if the survey is activated. Then try hiding the question using CSS (display: none).

This might make a difference because when using the "always hide this question" setting, no HTML for the question is generated at all while the CSS solution just hides the HTML.

I'm having the same problem as OP. I tried the above solution, but it doesn't work. It's not that the quota doesn't work, but that my Expression Manager code that is supposed to preset the value of a list type question doesn't seem to work if the question is invisible, regardless of whether this invisibility is achieved through "always hide this question" or CSS.

As a workaround, I think I will try to craft CSS that makes the question quite invisible to the human reader without actually touching the visibility attribute.
The administrator has disabled public write access.

Re: Setting up quota's with hidden question filled by prefilled URL answer 1 year 5 months ago #96314

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4293
  • Thank you received: 810
  • Karma: 373
Try:
#question123 {
	position: absolute;
	left: -9999em;
}

where "123" is your question ID.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: Setting up quota's with hidden question filled by prefilled URL answer 1 year 5 months ago #96316

  • ViliLe
  • ViliLe's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Thank you received: 1
  • Karma: 0
tpartner wrote:
Try:
#question123 {
	position: absolute;
	left: -9999em;
}

where "123" is your question ID.

Thanks for the idea. However, I discovered that actually the code that is intended to preset the value of a radio list doesn't seem to work at all under Safari, which I am using for testing at the moment. Under Chrome, where I originally tested, it seems to work, at least most of the time. So I now I'm not sure how much this problem ever had to do with visibility settings, and how much it's actually a cross-browser issue. I could test to find this out, but it's kind of pointless because if it doesn't work in Safari anyway, then I can't use it.

As a warning to others, after spending about 12 hours trying to implement a simple "Select your year of birth" -> (calculate age group) -> (apply quota based on age group) system, I'm giving up and just going the unelegant way of asking users to enter both their year of birth and age group.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.124 seconds
Donation Image