Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Unwanted waiting of 5 seconds after pressing submit button

Unwanted waiting of 5 seconds after pressing submit button 2 years 10 months ago #71115

  • Steve
  • Steve's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 494
  • Thank you received: 46
  • Karma: 17
Hello,

we have a problem with a survey. The navigation between the pages ("weiter"/"zurück") seems to be fast but after clicking "abschicken" (the "movesubmitbtn") we have to wait about 5 seconds (told by Firebug) until the completed message is shown. We tried several things like cheking the slow_queries and general_log tables in our MySQL database, measuring the time of the javascript functions using Firebug, measuring time using microtime() in index.php, save.php and adodb.inc.php but we can't figure out what creates this 5 seconds "waiting" time. The time difference seems to be okay (around 0.0065 micro seconds) but the waiting time seems to occur after pressing the submit button and before loading the index.php page.

Perhaps someone knows what could be the problem or what we can do to get to know what causes this problem.

Our LimeSurvey installation:
LimeSurvey 1.91+ Build 11379
Apache 2.2.17
PHP 5.2.17
MySQL 5.5.8 MySQL Community Server
Link to survey: umfragen.mvv.de/index.php?sid=76333&lang=de
Mit freundlichen Grüßen/Best regards,

Stefan Gohlke
LimeSurvey Team
The administrator has disabled public write access.

Re: Unwanted waiting of 5 seconds after pressing submit button 2 years 9 months ago #72077

  • TMSWhite
  • TMSWhite's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 759
  • Thank you received: 82
  • Karma: 36
are you sending email notifications? When I send email, I also find I get extra wait time, but haven't tried to track the root cause.
The administrator has disabled public write access.

Re: Unwanted waiting of 5 seconds after pressing submit button 2 years 9 months ago #72080

  • Steve
  • Steve's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 494
  • Thank you received: 46
  • Karma: 17
Hello,

yes, I use the detailed admin notification email because it was an important survey. One other (and shorter) survey also uses the detailed admin notification email but didn't seem to take as long as our "problem child".
Mit freundlichen Grüßen/Best regards,

Stefan Gohlke
LimeSurvey Team
The administrator has disabled public write access.

Re: Unwanted waiting of 5 seconds after pressing submit button 2 years 9 months ago #72123

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
I think this would be too obvious: "Navigation delay: Number of seconds before Previous and Next buttons are enabled. Default 0 seconds" -> docs.limesurvey.org/Creating+a+new+surve...ation_amp_navigation

Email might be an issue when using SMTP and a handshake between the servers has to be made and the like.

But all this is just a very rough guess...

Try using the online demo for testing to see if this is server related. The online demo at demo.limesurvey.org/admin always runs the latest Limesurvey version.
Username: admin
Password: test

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Unwanted waiting of 5 seconds after pressing submit button 2 years 9 months ago #72139

  • Steve
  • Steve's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 494
  • Thank you received: 46
  • Karma: 17
Hello,

I also thought about the navigation delay, but we set it to default 0 seconds.

We are using PHP (Standard) for the e-mails and it seems to work.

I tried to upload the survey to the online demo. The survey works well but I don't get a notification e-mail.

I think I'll test if this problem occurs with another template or try switiching to normal notification e-mail or disable it.
Mit freundlichen Grüßen/Best regards,

Stefan Gohlke
LimeSurvey Team
The administrator has disabled public write access.

Re: Unwanted waiting of 5 seconds after pressing submit button 2 years 9 months ago #72141

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
If you can track it down and reproduce it, please open a ticket at our bugtracker so we can try to fix it.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Unwanted waiting of 5 seconds after pressing submit button 2 years 8 months ago #72538

  • Steve
  • Steve's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 494
  • Thank you received: 46
  • Karma: 17
Hello,

we tried to track down the problem. It seems that our company has different SMTP servers and some don't work very well (though I don't know the specific settings of the SMTP server). I changed the "Email method:" from "PHP (default)" to "SMTP". The first two servers seem to have problem with it, the third server doesn't seem to have a problem it all.
Mit freundlichen Grüßen/Best regards,

Stefan Gohlke
LimeSurvey Team
The administrator has disabled public write access.

Re: Unwanted waiting of 5 seconds after pressing submit button 2 years 8 months ago #72557

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
Can you enable SMTP debug at global settings -> email and post the different error messages?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Unwanted waiting of 5 seconds after pressing submit button 2 years 8 months ago #72591

  • Steve
  • Steve's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 494
  • Thank you received: 46
  • Karma: 17
Slow: (about 6s)
SMTP -> FROM SERVER:221 2.0.0 Bye

Fast: (about 600ms)
SMTP -> FROM SERVER:221 2.0.0 xxx.xxx.xxx.de Service closing transmission channel (where xxx is the adress of the used server)
Mit freundlichen Grüßen/Best regards,

Stefan Gohlke
LimeSurvey Team
Last Edit: 2 years 8 months ago by Steve.
The administrator has disabled public write access.

Re: Unwanted waiting of 5 seconds after pressing submit button 2 years 8 months ago #72616

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
Hmm, that doesn't tell me much. Are those the only errors?

Is it possible that some Firewall causes trouble when establishing the SMTP connection?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.126 seconds
Donation Image