Welcome, Guest
Username: Password: Remember me

TOPIC: Edit Title in Source code mode and question about the & sign

Edit Title in Source code mode and question about the & sign 2 years 10 months ago #68040

  • Mike1985
  • Mike1985's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 49
  • Karma: 0
My customer wants an "&" sign in their survey title. I notice that there is not a "source" option for Title like there is with the other fields (i.e Description, Welcome, etc)..

If you put "&" in the field it stores it in the database as is. When you load the survey up, the title (even looking in the source code) is still "&". It doesn't convert to "&".

If you edit the field through phpMyAdmin, the changes are made and you do actually get "&" in the source code when you load the survey again.

Is this a potential flaw in LimeSurvey? Are there any risks for people using older browsers?

Any advice would be much appreciated.

Mike

PS I am working on version 1.90+
The administrator has disabled public write access.

Re: Edit Title in Source code mode and question about the & sign 2 years 10 months ago #68052

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
Why would this cause problems if you enter the "&" sign at the survey title instead of the "&" sign?

You can test if this is fixed at the latest version by testing our online demo at demo.limesurvey.org/admin(external link) which always runs the latest Limesurvey version.
Username: admin
Password: test
If you can reproduce the problem there and think this is a bug please report back.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Edit Title in Source code mode and question about the & sign 2 years 10 months ago #68059

  • Mike1985
  • Mike1985's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 49
  • Karma: 0
Because that's not correct HTML code. You're not supposed to have "&"s out there on their own. They should all be converted to "&"s.

Basic rules of HTML... or so I'm told!

Mike
The administrator has disabled public write access.

Re: Edit Title in Source code mode and question about the & sign 2 years 10 months ago #68065

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6334
  • Thank you received: 818
  • Karma: 243
Mike1985 wrote:
Basic rules of HTML... or so I'm told!
Only for url,

Not true in utf8, and LS use utf8 :).

Denis
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.117 seconds
Donation Image