Welcome, Guest
Username: Password: Remember me

TOPIC: Condition on question in group by group visualization doesn't work

Condition on question in group by group visualization doesn't work 2 years 10 months ago #66204

  • tuccio
  • tuccio's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Thank you received: 1
  • Karma: 0
Hello,
I have a problem on a condition in survey with group by group visualization.

I have a Q1 and Q2 dropdown questions. Q3 is displayed only if Q1 is not equal to Q2. All questions are in one group.

It works on question by question visualization, but doesn't work on group by group.

Can you help me?:(

My Limesurvey version is 1.91+ Build 11026, and this is the link to survey
The administrator has disabled public write access.

Re: Condition on question in group by group visualization doesn't work 2 years 10 months ago #66315

  • tuccio
  • tuccio's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Thank you received: 1
  • Karma: 0
Should I open a bug on bug tracker?
The administrator has disabled public write access.

Re: Condition on question in group by group visualization doesn't work 2 years 10 months ago #66322

  • machaven
  • machaven's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 14
  • Thank you received: 2
  • Karma: 6
Hi,

Please report it as a bug and attach a copy of the survey.
The administrator has disabled public write access.
The following user(s) said Thank You: tuccio

Re: Condition on question in group by group visualization doesn't work 2 years 10 months ago #66352

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5301
  • Thank you received: 291
  • Karma: 247
Please test if the problem still exists at the latest release. If so please open a ticket at the bugtracker and...
  1. Give as much information as possible
  2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.
  3. Provide step-by-step instructions how to reproduce the problem.
  4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
The following user(s) said Thank You: tuccio

Re: Condition on question in group by group visualization doesn't work 2 years 10 months ago #66390

  • tuccio
  • tuccio's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Thank you received: 1
  • Karma: 0
Thanks for instructions.
I've tested the problem on last version released.

I've already opened a bug on bug tracker. This is the link:
http://bugs.limesurvey.org/view.php?id=5483

I've also attached an example of survey with the problem.

To reproduce the problem we need:
  1. the first question radio button or dropped down Q1
  2. the second question radio button or dropped down Q2 with the same answer code of Q1
  3. the third question Q3 with the condition: show Q3 question only if Q2 is not equal to Q3
  4. all the question are onthe same group, the survey is displayed group by group

If I display the survey question by question the condition works, but I need a group by group visualization,sothis is a problem for me.

I've tested the problem with Firefox, Google chrome and Internet Explorer
Attached an example of survey.

thanks for your interest
Attachments:
The administrator has disabled public write access.

Re: Condition on question in group by group visualization doesn't work 2 years 10 months ago #66416

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5301
  • Thank you received: 291
  • Karma: 247
Please add all additional information at the bugtracker as well because our developers don't read at the forum much.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Condition on question in group by group visualization doesn't work 2 years 9 months ago #66523

  • tuccio
  • tuccio's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Thank you received: 1
  • Karma: 0
I've temporarily resolved with javascript and SGQA code. I notice the "java[SGQA]" variable don't keep the values.
The administrator has disabled public write access.

Re: Condition on question in group by group visualization doesn't work 2 years 9 months ago #66532

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5301
  • Thank you received: 291
  • Karma: 247
Thanks for your feedback!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.139 seconds
Donation Image