Welcome, Guest
Username: Password: Remember me

TOPIC: After label set import, label set does not appear in label sets dropdown

After label set import, label set does not appear in label sets dropdown 3 years 4 months ago #62931

  • dananrg
  • dananrg's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
I downloaded the World Countries label set csv here:

www.limesurvey.org/en/additional-downloads/func-finishdown/74/

The import seems to be successful. But then the label set does not appear in
Label sets administration > label sets dropdown for me to view, etc.

I'm using Version 1.91+ Build 10377 on a shared Linux host.

Assuming user error on my part, but I see nothing in the documentation that goes into more detail about this issue.

Thanks very much.
Last Edit: 3 years 4 months ago by dananrg.
The administrator has disabled public write access.

Aw: After label set import, label set does not appear in label sets dropdown 3 years 4 months ago #63185

  • jelo
  • jelo's Avatar
  • OFFLINE
  • Platinum Lime
  • Posts: 470
  • Thank you received: 52
  • Karma: 16
I tried to import the labelset with the newest version.

There is a error message when trying to import it from the php interpreter.
This might be suppressed on your website. You will only see that the import was successful. But it is not.

Warning: Invalid argument supplied for foreach() in /admin/importlabel.php on line 67

The labelset seems to be broken. Looks like an export of an question.
The LABELSETS TABLE is missing inside the file and an Answertable is provided.
Will not work without editing the file. Congo and VirginIslands are more then once included. A few " are missing too.

I have tried to fix it. The import should work now. The duplicates of Congo and VirginIsland are causing missing values. So check the labelset before using it.
Attachments:
Last Edit: 3 years 4 months ago by jelo.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.089 seconds
Donation Image