Welcome, Guest
Username: Password: Remember me

TOPIC: Comment field only save first five characters

Comment field only save first five characters 3 years 4 months ago #62323

  • gen72
  • gen72's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Hello, I have a complete survey done with this amazing software.
My problem is when the user fills with a comment a "Multiple choice with comments" question, only the first five characters are saved into database.
(The user write "Master" and on database only "Maste" is stored)

How can I solve it?

Thanks
Attachments:
The administrator has disabled public write access.

Re: Comment field only save first five characters 3 years 4 months ago #62402

  • gen72
  • gen72's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
I have solved this problem modifying the field on database from varchar(5) to varchar(80).
Somebody knows if this change on database can cause any problems in the future?

Thanks
The administrator has disabled public write access.

Re: Comment field only save first five characters 3 years 4 months ago #62414

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4270
  • Thank you received: 804
  • Karma: 368
This sounds like a bug. Are you using the latest stable version?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: Comment field only save first five characters 3 years 3 months ago #62819

  • Yurij
  • Yurij's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
The administrator has disabled public write access.

Re: Comment field only save first five characters 3 years 3 months ago #63385

  • mmoloi
  • mmoloi's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Changing the field type from varchar(5) to varchar(80) has no implications as it just saying increase the number of characters I can store in that field - And yes an answer to your question was the issue of varchar(5).
The administrator has disabled public write access.

Re: Comment field only save first five characters 2 years 6 months ago #78267

  • hrshdhgd
  • hrshdhgd's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 29
  • Karma: 0
hey gen72,

I need to change varchar(5) to varchar(255) but I don't know where to change the settings. Could you guide me regarding this issue?

Thanks in advance,
H.
The administrator has disabled public write access.

Re: Comment field only save first five characters 2 years 6 months ago #78272

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2845
  • Thank you received: 358
  • Karma: 124
This problem should be long solved. What is the problem you need to solve?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: Comment field only save first five characters 2 years 6 months ago #78303

  • hrshdhgd
  • hrshdhgd's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 29
  • Karma: 0
I have a problem where in when I import an external database into LimeSurvey (the database is modified to comply with the import requirements), I get an error message for all the entries which have long comments (in the 'others' option of my survey) saying that the data is too long for a varchar(5) data type declared column. I want to change the varchar(5) data type of those columns to varchar(255). All other entries without comments have been imported successfully.

The exact error message "[ERROR: value too long for type character varying(5)]"

Thanks in advance,
H.
Last Edit: 2 years 6 months ago by hrshdhgd. Reason: error message inclusion
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.118 seconds
Donation Image