Welcome, Guest
Username: Password: Remember me

TOPIC: Multiple numeric questions and decimals

Multiple numeric questions and decimals 3 years 3 months ago #61539

  • agully
  • agully's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 5
  • Karma: 0
Strange issue that is causing my survey problems. My survey is set up all-in-one with each question being mandatory. Several of the questions are multiple numeric type. If the respondent misses a question and the survey kicks it back with errors then all the numbers in number text boxes are replaced with non-integer values. For example, if one entered all zeros in the number boxes, misses a question, when they return all zeros will become 0.0.

This is causing issues because the conditions filter does not recognize 0.0 to be same as 0. So if I have a question after the multiple numeric set to display if any answer in the previous question is > 0, it will show up if 0.0 is entered. So the respondent is forced to re-enter all the numbers to get things to work properly.


If that's not strange enough, I am only able to replicate this behavior on an IIS server using MSSQL db--which is my main environment for the live survey. My development and testing environment for limesurvey (apache & MySQL) this problem can NOT be replicated. Otherwise the installation is the same version.

Any ideas here? Are there any logical reasons why the ISS and MSSQL combination could be causing this? Or is there another explanation I'm not seeing.

Thanks
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.090 seconds
Donation Image