Welcome, Guest
Username: Password: Remember me

TOPIC: multi numeric - slider, inital value dont register

Re: multi numeric - slider, inital value dont register 2 years 10 months ago #66620

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
Bumping / reactivating this: It seems that the initial value is set when testing the survey. But after the survey has been activated the initial value is not set?

The initial value also seems to be set when previewing the group/question.

Strange?
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 2 years 10 months ago #66635

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
This is a demo survey: The slider value questions are on page two. skema.dzidzo.dk/31118/
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 2 years 10 months ago #66647

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 293
  • Karma: 248
lovepade wrote:
Bumping / reactivating this: It seems that the initial value is set when testing the survey. But after the survey has been activated the initial value is not set?

The initial value also seems to be set when previewing the group/question.

Strange?
1. Which Limesurvey version do you use?

2. Can you attach your question for testing?

3. Can you explain what problem shows up and which shoud be the behavior you expect?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 2 years 10 months ago #66654

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
Hi Mazi, Thanks

1. I use the latest version: Version 1.91+ Build 11026
2. See the link above for the whole survey. Attached is one specific question.
3. Problem: Using a slider layout with an initial value defined, I expect that the initial value is saved as an input, if the user doesn't change the initial value. So if I e.g. have 4 questions each with an initial value of 5, and a validation that defines "Equal sums value" to 20, then I should be able to just click through to the next page. But instead I am asked to define twenty points.

The survey/question behaves as expected when the survey is deactived, and when previewing a question or a question group. But when doing an actual activated survey, the initial value is not saved.

(Edit: Spelling)
Attachments:
Last Edit: 2 years 10 months ago by lovepade.
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 2 years 10 months ago #66655

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 293
  • Karma: 248
I can't reproduce the problem. When activating the survey with just your question I can click submit and there is no error. The "total" field shows a green "100" entry.

Test 2: If I add your question twice and running the survey question by question I can reproduce the problem. The second question shows a red "total" field though all should sum up fine.

Test 3: In all in one mode all works fine.

So please open a ticket at the bugtracker and...
  1. Give as much information as possible
  2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.
  3. Provide step-by-step instructions how to reproduce the problem.
  4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
Last Edit: 2 years 10 months ago by Mazi.
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 2 years 10 months ago #66657

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
Ok thanks: What happens if you use this link: skema.dzidzo.dk/31118/

Is it possible that the question works as intended in preview mode, and in single-groups surveys, but not in e.g. multi-groups surveys?
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 2 years 10 months ago #66685

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
Thanks Mazi,

Only saw your edit now. This is the link: bugs.limesurvey.org/view.php?id=5488
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 2 years 10 months ago #66704

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 293
  • Karma: 248
Thanks, we'll have a look at it.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 2 years 10 months ago #66712

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
Cheers. I really hope there is a fix for this.... Keeping my fingers crossed and my prayers focused on the german bugkillers and php-kings.
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 2 years 10 months ago #66714

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 293
  • Karma: 248
I assigned this ticket to a developer from France so it might take a while because he mainly does bugfixing at the weekend due to his full time job.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.131 seconds
Donation Image