Welcome, Guest
Username: Password: Remember me

TOPIC: multi numeric - slider, inital value dont register

Re: multi numeric - slider, inital value dont register 3 years 3 weeks ago #66717

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
Well - I'll donate even if it takes more then 24 hours :-) I just hope I can have it working locally by sunday evening. Otherwise I must change the survey. Thanks for all the effort and attention you are putting in to this.
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 3 years 3 weeks ago #66732

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5333
  • Thank you received: 296
  • Karma: 249
I first (untested) fix was just released. You can test the updated file here: limesurvey.svn.sourceforge.net/viewvc/li...ision&revision=11094

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 3 years 3 weeks ago #66735

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
Fantastic news. I'll test it right away. Basically I'll just overwrite the old qanda.php?
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 3 years 3 weeks ago #66736

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
Okay - thanks. We are almost - but not quite there.

the issue with persistency / registration of the initial value seems to be resolved. But something has messed up the slider design. Se attached screenshot: Theres is an inputbox visible where there should only be a slider? I hope this explanation makes sense?
Attachments:
Last Edit: 3 years 3 weeks ago by lovepade.
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 3 years 3 weeks ago #66739

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4281
  • Thank you received: 807
  • Karma: 370
I don't see that with the fix in IE or Firefox. Do you have any custom scripts running?

Can you please try with the attached survey in the default template?

File Attachment:

File Name: limesurvey_survey_42781.lss
File Size: 34 KB



Capture4_2011-10-04.PNG
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 3 years 3 weeks ago #66740

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
Well - yes I still see the input boxes? just tried on firefox 7 and chrome 16. (mac os x).

Weird.

EDIT: I just got home and tried on chrome stable, linux. Still the input boxes show up. I tried with default template, limespired and eirenicon.

This is the culprit:
<input class="text" type="text" name="42781X224X27011" id="answer42781X224X27011" value="25"
">

I guess I can hide the input box with e.g.
#answer42781X224X27011 {
    display: none;
}
... but it's not very elegant :-)
Last Edit: 3 years 3 weeks ago by lovepade. Reason: codefix
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 3 years 3 weeks ago #66743

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4281
  • Thank you received: 807
  • Karma: 370
Can you activate a sample survey for me to test?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 3 years 2 weeks ago #66764

  • lovepade
  • lovepade's Avatar
  • OFFLINE
  • Expert Lime
  • Posts: 93
  • Karma: 0
Hi tpartner,
I'd be glad to. This is the your own test survey, with the limespired template. skema.dzidzo.dk/42781/lang-en
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 3 years 2 weeks ago #66768

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5333
  • Thank you received: 296
  • Karma: 249
Using the linked test survey I can reproduce the problem on Firefox 3.6:

sliderbug.png

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: multi numeric - slider, inital value dont register 3 years 2 weeks ago #66785

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4281
  • Thank you received: 807
  • Karma: 370
This is very odd, I can't reproduce this with the latest release (11102).

Marcel, can you reproduce on your system?

lovepade, did you update your whole <a href='www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey'>installation</a> or just quanda.php?

This is what I see:

Capture5.gif
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
Last Edit: 3 years 2 weeks ago by tpartner.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.240 seconds
Donation Image