Welcome, Guest
Username: Password: Remember me

TOPIC: Error possibly related to conditions

Error possibly related to conditions 3 years 5 months ago #57402

  • joeeebean
  • joeeebean's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
I'm programming a survey about networks. We're surveying 42 different departments that have between 5 and 45 people in them. In the survey, everyone gets certain base questions, but there are three network questions that are tailored to what department the respondent belongs to. The first network question is #9. There are 42 versions of this question (one for each department - 9_1, 9_2, etc.). I have an attribute in the token table that tells what department each person belongs to. So everyone who belongs to department 1 gets 9_1, everyone from department 2 gets 9_2... everyone who belongs to department 42 gets 9_42. In question 9, they are asked to assess every other person in their department. The same thing happens for questions 11 and 13. There are 754 people total so the database gets too big, which forced me to program this as four separate, but identical surveys with about 10 departments in each one.

Three of my surveys work perfectly when I test them in test mode and in active mode (with and without conditions set). But one of them is being a bear. If I take out all conditions, it works fine. If I put in all conditions and run it in test mode, it works fine as well. But when I activate it I get problems. I can get to question 9 just fine, but cannot get past it. Instead, I get an error (Error: We are sorry but your session has expired.
Either you have been inactive for too long, you have cookies disabled for your browser, or there were problems with your connection.). I'm not doing anything different with this version than with the others (i.e., taking the same time, cookies are set the same, etc.).

Does anyone have any idea what is happening here? I'm running out of time to get this working very quickly!

Any help is appreciated. Thanks.
The administrator has disabled public write access.

Re: Error possibly related to conditions 3 years 5 months ago #57407

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5302
  • Thank you received: 291
  • Karma: 247
Try to set up the according question from scratch and maybe also all question that conditionally depend on this question.
Also check for chained conditions that are not valid.

You can also try to delete conditions and re-set them from scratch.

Are there any errors at the servers error log?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.101 seconds
Donation Image