Welcome, Guest
Username: Password: Remember me

TOPIC: Datepicker defaulting to 1980

Datepicker defaulting to 1980 3 years 6 months ago #56812

  • stitcho
  • stitcho's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
I've just upgraded to RC3 of Limesurvey and noticed that the datepickers on my surveys have now changed to default to 1st Jan 1980. They never did this before and defaulted to the current date.

Anyway I rolled back to the last stable build because I was running into problem after problem with RC3 and the problem still seems to exist. I have rolled back all the files and the database so it should be in the same state as before I tried to upgrade.

I can alter the min date in the qanda.php file but I don't know which function I need to change for the default. Can anyone possibly assist?

Version: 1.90 #9642
PHP: 5.2.14
The administrator has disabled public write access.

Re: Datepicker defaulting to 1980 3 years 6 months ago #56836

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 294
  • Karma: 249
If this worked fine at 1.90 but default=today has changed at 1.91RC please open a ticket at the bugtracker and...

1. Give as much information as possible

2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.

3. Provide step-by-step instructions how to reproduce the problem.

4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Datepicker defaulting to 1980 3 years 6 months ago #56892

  • stitcho
  • stitcho's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 13
  • Karma: 0
Thanks for the reply Mazi but I'm no longer on an RC version.

$versionnumber = "1.90+";
$dbversionnumber = 143;
$buildnumber = '9642';

I just cant seem to find the code that tells it to default to today but I restored everything back to how it was before I tried upgrading and I'm still getting problem so I dont know what has changed.
The administrator has disabled public write access.

Re: Datepicker defaulting to 1980 3 years 6 months ago #56897

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 294
  • Karma: 249
You can test if this is fixed at the latest version by testing our online demo at demo.limesurvey.org/admin(external link) which always runs the latest Limesurvey version.
Username: admin
Password: test
If you can reproduce the problem there please open a bug report.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.106 seconds
Donation Image