Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: ClassId Appeared on top of the screen.

ClassId Appeared on top of the screen. 3 years 7 months ago #55045

  • dunokobi
  • dunokobi's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Major problem, I have created a survey through my notebook and I transfer it to my server. The main thing is when I view it from my notebook, it doesn't appear to have any problem regarding about the screen and view. Even condition been set correctly.

However when I transfer to my server, everything turn upside down. Class ID seems to be appear on top of the screen but not all. Some of it happen to have this case. Even I try to change some words though it, once i press update, it will go differently(probably i should say like it is not updated at all) or sometimes it will be deleted.

May I know how can I solve this problem? Any1 know what is happening? I am unable to figure out the meaning of this.

Your help is so much appreciated. Thanks.

*Note: Using Xampp server and Limesurvey 1.86v for both. notebook and server.
Last Edit: 3 years 7 months ago by c_schmitz.
The administrator has disabled public write access.

Re: ClassId Appeared on top of the screen. 3 years 7 months ago #55052

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 753
  • Thank you received: 104
  • Karma: 87
Hello!

Could be various things - but we would only be able to help you if you are using the latest version (1.90) anway. So my first recommendation would be to update to the latest version first and see if the issue is resolved by then.
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Re: ClassId Appeared on top of the screen. 3 years 7 months ago #55055

  • dunokobi
  • dunokobi's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Hi C_schmitz

I m nt sure the latest version is workable or nt cause I used the 1.90v before this but unable to export old survey to the new one. Moreover the problem itself is when I create the survey through mozilla firefox and it will automatically change the coding to CSS. However when i use IE to create my survey question, it will remain as HTML code.

When I used IE to create the survey, it have nothing happen with any coding on top my question that been viewed. It just happen when I used Mozilla firefox to create the questionaire.

Is there any possibility that Browser Compatibility will effect on the limesurvey?

Thanks
The administrator has disabled public write access.

Re: ClassId Appeared on top of the screen. 3 years 7 months ago #55061

  • c_schmitz
  • c_schmitz's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 753
  • Thank you received: 104
  • Karma: 87
dunokobi wrote:
Hi C_schmitz

Is there any possibility that Browser Compatibility will effect on the limesurvey?


Usually not. As said, it is an old version you are using. I don't remember every single issue that existed. Upgrading is your friend ;).
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Re: ClassId Appeared on top of the screen. 3 years 7 months ago #55152

  • dunokobi
  • dunokobi's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Hi C_schmitz

The following attachment is the code that appear when I used Mozilla to create my questionnaires which is auto-generate by Limesurvey. From what I read about Log on upgrading, it doesn't stated the browser compatibility as well. Are you sure by upgrading the system will improve on that? Is there any alternative way to solve this problem?

*note* My company have just made upgrading on limesurvey and we tested the newest version before we go back to this 1.86v. Newest version have a lot of different code which we are unable to copy the old question to new one. So it is kinda troublesome. What I mean by unable to copy the old version to new one is like the condition will be set as 0 n some question will went missing. It will take a lot of time to regenerate the questionaire.


File Attachment:

File Name: mozilla.txt
File Size: 1 KB
The administrator has disabled public write access.

Re: ClassId Appeared on top of the screen. 3 years 7 months ago #55163

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4119
  • Thank you received: 760
  • Karma: 346
Did you copy and paste your questions from an MS Word doc? Try pasting them from a plain-text editor like Notepad++.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: ClassId Appeared on top of the screen. 3 years 7 months ago #55191

  • dunokobi
  • dunokobi's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Hi Tpartner

I copy from MS Doc straight away and paste into my question.

I did try on using the way you have just teach me and surprisingly it work. May I know why I can't paste straight away from MS Doc rather then using Notepad?

Thanks for your info.
The administrator has disabled public write access.

Re: ClassId Appeared on top of the screen. 3 years 7 months ago #55198

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 293
  • Karma: 248
When copying from MS Word lots of layout/style information is copied at the background. You'll see that when having a look at the question text in source code mode.
This additional data can cause problems when displaying the question at the survey. Therefore we always recommend to copy to a raw text editor first (you can even copy/paste to the browsers search field top right) and then copy that text to Limesurvey.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: ClassId Appeared on top of the screen. 3 years 7 months ago #55276

  • dunokobi
  • dunokobi's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Hi Mazi.

Thanks for your information, Mazi

Is that means that if I copy straight away from MS word, it will autogenerate a different coding for limesurvey? But why is the problem only facing with firefox rather than IE?

Even for IE, I copy straight away from MS word as well.

Mind letting me know?

Thank you again for all your help to clear my doubt.
The administrator has disabled public write access.

Re: ClassId Appeared on top of the screen. 3 years 7 months ago #55280

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2610
  • Thank you received: 302
  • Karma: 112
MS Word is generating loads of stupid code in the back. When you copy the text, you also copy the stupid code (that you won't see in MS Word).

When you copy this to Limesurvey the browser won't know that is not to display. IE probably knows that this weird code is from MS Office doesn't show. Would be interesting if IE already gets rid of it before copying into Limesurvey (then it should show in the code view), or the IE just doesn't display this code, even it is there.

Makes sense?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.155 seconds
Donation Image