Welcome, Guest
Username: Password: Remember me

TOPIC: 2 part survey - connected

Re: 2 part survey - connected 3 years 5 months ago #57963

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2607
  • Thank you received: 302
  • Karma: 110
If you use a survey with tokens then each token can only be used once, so you can't do the same survey again. You either have to provide different tokens or you have to make a survey without tokens.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
The following user(s) said Thank You: phschwager

Re: 2 part survey - connected 3 years 5 months ago #57966

  • phschwager
  • phschwager's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Thanks, I think I figured out a way to make it work with 2 surveys. The first one uses tokens. Then in the Thank You for completing the first part e-mail I send them a link to the second part. The second part passes the token as a question answer so now I can tie the two parts together. It worked in a small version, now I just need to make the bigger surveys :-)

Here is the link where I found how to insert the variable. Just had to call the token variable.

docs.limesurvey.org/Workarounds%3A+Surve...using_the_survey_URL
The administrator has disabled public write access.

2 part survey - connected 1 year 4 months ago #94820

  • Lila86
  • Lila86's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Dear all,
basically, I have a very similar question as phschwager.
I want to measure the responses of the participants twice but need their responses to appear in one dataset so that their answers are connected.

My procedure looks like this:
I will e-mail the survey URL to selected participants - without using tokens. They finish the first part. After two or seven days, I will send them a reminder with the URL to the second part.
A lot of participants would be filling in the first and second part simultaneously. (Is the solution offered to phschwager then still possible?)

I have already tried to follow the suggested steps in this forum post, but it does not work properly and I do not know where the mistake lies.
- I have created 1 survey intented to include the two parts.(Survey ID=89882)
- I have created a Group=hidden question (ID=1424) with 1 MCQuestion=Measurementmoment with 1 answeroption = "part2" (ID=25466).
- Then I created a lot of questions for part one. With no conditions.
- Then I created conditions for all the questions that should only be seen in the second part.
I could either create a condition for the group (parts) or the MCQ answeroption (marked/not marked). So i defined two conditions to be sure.
1. Show Qx if Measurementmoment=part2
2. Show Qx if Measurementmoment:SQ001=marked.
In the end the Condition looks the same: Relevance: ((Measurementmoment_SQ001.NAOK == "Y") and (Measurementmoment_SQ001.NAOK == "Y"))
- Then I adapted the reminder URL as suggested by Mazi.
The first URL link send to participants ends like this: ?sid=89882&lang=nl
Accordingly, I thought the second URL should end like this: ?sid=89882&gid=1424&qid=25466=part2
I tried several versions of adding =part2 to the URL, but none works. Additionally, I get the message "this survey does not yet contain any questions".

Apparently, I must have made a mistake. But where? Can you help me?
Is it the URL?
Is it the HiddenQuestion? (Should i have chosen "Equation" as questiontype? If yes, what would the question field read?)
Is it the Condition?
Or is it a combination of all three?

Many thanks for your response and help!


PS: I am using lime-survey 1.92.
The administrator has disabled public write access.

2 part survey - connected 1 year 4 months ago #94821

  • Mazi
  • Mazi's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 293
  • Karma: 248
1. Can you attach your survey for testing?

2. The URL to the second part is wrong, it has to look like this (couldn't test yet):
?sid=89882&lang=nl&89882X1424X25466_SQ001=Y

Maybe this URL work, too:
?sid=89882&lang=nl&Measurementmoment_SQ001=Y

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

2 part survey - connected 1 year 4 months ago #94825

  • Lila86
  • Lila86's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Many thanks for such a quick response.

1. surveys-igs.utwente.nl/index.php?sid=89882&lang=nl (this would be the initial link)

I tried using the following URL, but it justs starts with the first question of the first part.
surveys-igs.utwente.nl/index.php?sid=898...rementmoment_SQ001=Y

Addtionally, I set the conditions for the first part of the survey only to show if: Relevance: ((Measurementmoment_SQ001.NAOK != "Y"))
But this did not work either.
The administrator has disabled public write access.

2 part survey - connected 1 year 4 months ago #94831

  • Mazi
  • Mazi's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 293
  • Karma: 248
The switch question ("Measurement..." has to be placed at the very beginning of the survey. You can't set a condition at question 2 based on the answer of a question on a following page which is usually not know/not defined.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

2 part survey - connected 1 year 4 months ago #94837

  • Lila86
  • Lila86's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
The "measurement" question already is at the very beginning of the survey.
It's the following order:
Welcome message
Measurementmoment (hidden)
Part one questions - Randomisation, Attitude (conditioned)
Part two questions (conditioned)

Do you reckon the problem lies with defining the hidden question, or the conditioning? Since you have indicated how the 2nd URL should look like that should not be the problem, right?
The administrator has disabled public write access.

2 part survey - connected 1 year 4 months ago #94838

  • Mazi
  • Mazi's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 293
  • Karma: 248
Please attach the survey for testing.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

2 part survey - connected 1 year 4 months ago #94840

  • Lila86
  • Lila86's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Can you see the file I uploaded?
Last Edit: 1 year 4 months ago by Lila86.
The administrator has disabled public write access.

2 part survey - connected 1 year 4 months ago #94841

  • Mazi
  • Mazi's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 293
  • Karma: 248
I see no file. Export it as .LSS file and then attach it here using the forum's editor.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.140 seconds
Donation Image