Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Array Filter works badly in IE6

Array Filter works badly in IE6 4 years 4 weeks ago #52553

  • jessego
  • jessego's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Version: 1.90+ Build 9118

Hey, everybody
Array Filter works fine in all browsers expect the legend IE6.

I have 2 Questions:

Q1 (Multiple Options)
Q2 (single choice: list radio)

Q1 & Q2 have exactly the same 26 options. I set an array filter in Q2 based on Q1 answers.

Ok, it works, Even in IE6.

The Problem is: In IE6, when I click a option in Q1, the "√" symbol and the corresponding option in Q2 appears after 1 seconds at least. This delay is unbearable.

I've tried several servers meeting the same problem. However, when I decrease the number of the options. Works fine in IE6.

I wonder if array filter has bad implementation. or, IE6 sucks.

plz help
The administrator has disabled public write access.

Re:Array Filter works badly in IE6 4 years 4 weeks ago #52554

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3013
  • Thank you received: 386
  • Karma: 124
jessego wrote:
I wonder if array filter has bad implementation. or, IE6 sucks

Well, probably both. IE6 sucks, that is a fact and we don't have to discuss it. :lol:

Now, the array filter should work also for the IE6.

Let's see if some of the developers can help here.

Is this problem reproducible on other machines with IE6?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:Array Filter works badly in IE6 4 years 4 weeks ago #52559

  • DenisChenu
  • DenisChenu's Avatar
  • NOW ONLINE
  • Moderator Lime
  • Posts: 6665
  • Thank you received: 888
  • Karma: 263
holch wrote:
Now, the array filter should work also for the IE6.
Here , it work with IE6,
slow but working,

Google doesn't support completely IE6 for gmail or agenda, i don't think LS team can do more.
The administrator has disabled public write access.

Re:Array Filter works badly in IE6 4 years 4 weeks ago #52560

  • jessego
  • jessego's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Is this problem reproducible on other machines with IE6?

Yes, i've tried several mechines with IE6. And I've used another survey application to implement the same function. It works fine in IE6.

now I'm checking the automatic generated Javascript code :(
The administrator has disabled public write access.

Re:Array Filter works badly in IE6 4 years 4 weeks ago #52562

  • jessego
  • jessego's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Google doesn't support completely IE6 for gmail or agenda, i don't think LS team can do more

well, i think the user experience in the survey seems more critical. If I am the user, in this situation, I'll probably think there's something wrong with my computer or browser, and I'll close the window.

That's really bad for a survey, right?
The administrator has disabled public write access.

Re:Array Filter works badly in IE6 4 years 4 weeks ago #52564

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3013
  • Thank you received: 386
  • Karma: 124
Shnoulle wrote:
Google doesn't support completely IE6 for gmail or agenda, i don't think LS team can do more.

Well, Shnoulle, here I do not agree. While someone providing an email service can decide to not cover certain browsers, we as a survey tool can't. Why? Because it is a survey tool! For surveys we often rely on representativity. If a vital component of a survey (which the Array Filter could be) would not work for specific browser, we have a problem. Unfortunately that stupid IE6 seems to be immortal and we have to live with it. It is one thing if the layout isn't 100% the same, but if for the IE6 users all options in question 2 are shown, despite the array filter, then this is not good, because this has an impact on the results.

I thought the array filter would be implemented via php, but it seems like it is javascript, right?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re:Array Filter works badly in IE6 4 years 4 weeks ago #52568

  • DenisChenu
  • DenisChenu's Avatar
  • NOW ONLINE
  • Moderator Lime
  • Posts: 6665
  • Thank you received: 888
  • Karma: 263
holch wrote:
I thought the array filter would be implemented via php, but it seems like it is javascript, right?
Javascript if the 2 question are on the same page, it's the only way.

I think it's in php for different page, have to verify :)

And : i prefer to work for limesurvey ability for accessibility than for IE6.

Array filter don't work with alinks too :)
Last Edit: 4 years 4 weeks ago by DenisChenu.
The administrator has disabled public write access.

Re:Array Filter works badly in IE6 4 years 4 weeks ago #52577

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3013
  • Thank you received: 386
  • Karma: 124
Shnoulle wrote:
holch wrote:
I thought the array filter would be implemented via php, but it seems like it is javascript, right?
Javascript if the 2 question are on the same page, it's the only way.

For questions on the same page this makes total sense.
I think it's in php for different page, have to verify :)

So you think there were 2 different methods applied?
And : i prefer to work for limesurvey ability for accessibility than for IE6.

Well, somehow providing the functionality for IE6 is providing accessibility as well, right? Accessibility isn't necessarily limited to screen readers, etc. It means to provide access to as many people as possible, without discriminating. We can't discriminate IE6 users, can we? ;-)

And besides the discrimination issue, it is simply a research thing. If you tell a client, that your survey doesn't work properly with IE6, I would be surprised if he/she would be happy. And with good reason. Unfortunately the IE6 still lives on, especially because of some intranet applications, that use the holes in IE6 to provide intranet functionality they could never provide using a "proper" browser.

According to my secret internal sources at Microsoft (MSN), they are pretty annoyed about the IE6 themselves. Hehehehe.
Array filter don't work with alinks too :)

I didn't get this part.

***made some corrections due to horrible English***
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Last Edit: 4 years 4 weeks ago by holch.
The administrator has disabled public write access.

Re:Array Filter works badly in IE6 4 years 4 weeks ago #52582

  • jessego
  • jessego's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
We can't discriminate IE6 users, can we?

Agree with that. :)
only stand in the side of users can the production survive.

The survey was planned to go live tomorrow. It seems I have to put it off :dry:
The administrator has disabled public write access.

Re:Array Filter works badly in IE6 4 years 4 weeks ago #52583

  • Mazi
  • Mazi's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 5504
  • Thank you received: 312
  • Karma: 253
jessego wrote:
Is this problem reproducible on other machines with IE6?

Yes, i've tried several mechines with IE6. And I've used another survey application to implement the same function. It works fine in IE6.

now I'm checking the automatic generated Javascript code :(
Please test if the problem still exists at the latest release. If so please open a ticket at the bugtracker and...

1. Give as much information as possible

2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.

3. Provide step-by-step instructions how to reproduce the problem.

4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.134 seconds
Donation Image