Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: session expired solutions don't work

session expired solutions don't work 4 years 5 months ago #40893

  • Dondebile
  • Dondebile's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Hi,

I get an error message saying
"ERROR
We are sorry but your session has expired.
Either you have been inactive for too long, you have cookies disabled for your browser, or there were problems with your connection."

Of course I browsed as many forum posts to this topic as possible and apply the solutions. Unfortunately none of them worked.

I'm using limesurvey version Version 1.87+ Build 8518

Here's what I did so far:


- raising $sessionlifetime in config.php
- raising session.cookie_lifetime = 7200 in php.ini)
- my firefox browser uses cookies until they are expired
- php.ini on server uses cookies and only cookies
- tried to insert ini_set('session.use_trans_sid', true); ini_set('session.use_cookies', false); into index.php (deleted it again later)
- rised $memorylimit = "16M"; to $memorylimit = "1024M"; or "32M"; respectively in config.php
- rising session duration in global settings in the user interface
- rising session.gc_maxlifetime = 7200 in php.ini


- I did NOT change session.cookie_path = /, and session.cookie_domain = in the php.ini (because I don't know what or how to fill in the information there)


Please can anybody help? My study has to run in a week and I'm just getting absolutely crazy because I don't know what to do. Of course I'll also donate if I get this working, you guys are doing a great job.

Thanks
Jürgen
Last Edit: 4 years 5 months ago by Dondebile.
The administrator has disabled public write access.

Re:session expired solutions don't work 4 years 5 months ago #40902

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
Did you try to raise session lifetime in your php.ini file?

Always remember to restart your webserver after having changed such settings.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:session expired solutions don't work 4 years 5 months ago #40921

  • Dondebile
  • Dondebile's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
yes I did (sorry forgot to mention...).this is what is the state in php.ini in this moment:
session.gc_maxlifetime = 7200

any other suggestions? please :)
The administrator has disabled public write access.

Re:session expired solutions don't work 4 years 5 months ago #40929

  • Dondebile
  • Dondebile's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
By the way: I don't have a local apache server, I've bought webspace at fatcow.com and I can't restart that server, can I?
The administrator has disabled public write access.

Re:session expired solutions don't work 4 years 5 months ago #40935

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6334
  • Thank you received: 818
  • Karma: 243
Did you use url_rewriting ?

I have the same problem with links like that :
mylimesurvey/limesurvey/XXXXX/lang-fr.
(see google)

I look for my problem this week end if i can, but maybe we had the same problem.
The administrator has disabled public write access.

Re:session expired solutions don't work 4 years 5 months ago #40936

  • Dondebile
  • Dondebile's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
nope. No url_rewriting found in php.ini, index.php or config.php.
The administrator has disabled public write access.

Re:session expired solutions don't work 4 years 5 months ago #40940

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4195
  • Thank you received: 789
  • Karma: 359
This maybe a dumb question but have you tried another browser to see if it's a cookie problem?

Also, check for URL rewriting in your .htaccess file (although, it doesn't sound like a rewrite problem).
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re:session expired solutions don't work 4 years 5 months ago #40945

  • Dondebile
  • Dondebile's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
also no url_rewriting in htaccess.txt found. It says RewriteEngine On at the top if that helps anything.

It also didn't work for Internet Explorer. But anyways all the survants will use firefox on prepared laptops.

I also installed Drupal on my server. When I login there, I don't have a problem with the sessionlifetime.

Also when I try to create a survey and I am inactive for more than 2-3minutes it will log me out. Is that normal?
Last Edit: 4 years 5 months ago by Dondebile.
The administrator has disabled public write access.

Re:session expired solutions don't work 4 years 5 months ago #41034

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
Please contact your provider to ask what else you can do to raise session lifetime.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re:session expired solutions don't work 4 years 5 months ago #41090

  • Dondebile
  • Dondebile's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 6
  • Karma: 0
Solved it. It was indeed a server problem. This is a solution for all you out there with fatcow webspace:
Fatcow seems to have two php.ini. One you can access via the File Manager (Website > Filemanager) (let's call it php.ini1), one you can access via the menu Scripting and Add-Ons > CGI and scripted language support > PHP scripting (let's call it php.ini2). php.ini1 only contains one line of code: register_globals = false, php.ini2 contains a lot of code.

Solution: Simply delete the php.ini1 in the filemanager. This is also the php.ini you can access via a ftp-programm like filezilla, so if you wish you can also delete it there.

I don't know if you have to insert the register_globals = false from php.ini1 into php.ini2, but my survey worked perfectly for me now, concerning the mentioned problem.

Thank you all your time and energy, I'm really appreciating that. Yes I will donate now.
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.128 seconds
Donation Image