Welcome, Guest
Username: Password: Remember me

TOPIC: Referencing token in admin email

Referencing token in admin email 4 months 3 days ago #110039

  • ohvelma
  • ohvelma's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 39
  • Thank you received: 1
  • Karma: 1
I want to reference the token from the subject line of the admin email sent when a survey is submitted. Here is what I have been trying:

Basic admin notification subject: {SURVEYNAME} on {SurveyDate} Packet # {TOKEN}

Survey name gets replaced with the actual survey name. SurveyDate is the name of a question on the survey and it also gets replaced with the correct value, in this case it is defaulting to the current date, so at the moment I am getting "06-16-2014".

HOWEVER the token syntax does not appear to work as easily. I have tried:
{TOKEN}
{TOKEN:TOKEN}
{Token}
{token}

At this point I am running out of guesses AND survey responses (I don't want to buy more just for testing) so does anyone have any suggestions?

I really want to have the token in the subject line of the admin email because we use that information to sort the email without having to open it.

Thanks for any help you can give!

Carole
Attachments:
Last Edit: 4 months 3 days ago by ohvelma. Reason: Adding Picture
The administrator has disabled public write access.

Referencing token in admin email 4 months 2 days ago #110052

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4256
  • Thank you received: 801
  • Karma: 367
Sounds like a bug.

Please file a bug report and...
  1. Give as much information as possible.
  2. Provide step-by-step instructions how to reproduce the problem.
  3. Provide screenshots and/or a sample survey.
  4. Post the link to the bug here so we can follow the progress.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
The following user(s) said Thank You: DenisChenu

Referencing token in admin email 4 months 2 days ago #110061

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6429
  • Thank you received: 839
  • Karma: 249
And test with the last version, because we already fix some issue with token in admin email.

PS:
{TOKEN:FIRSTNAME} work for a lot of day (if survey is NOT anonymous).
Last Edit: 4 months 2 days ago by DenisChenu.
The administrator has disabled public write access.

Referencing token in admin email 4 months 2 days ago #110069

  • ohvelma
  • ohvelma's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 39
  • Thank you received: 1
  • Karma: 1
I can't reproduce for now ... I am using LimeQuery and used up all my responses for the month just trying to get this to work. I have to raise the balance before I can do ANYTHING. Grr! I need a bug refund! Ha, ha!
The administrator has disabled public write access.

Referencing token in admin email 4 months 2 days ago #110071

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6429
  • Thank you received: 839
  • Karma: 249
Hi,

Not sure it's the good link : www.LimeService.com/support
The administrator has disabled public write access.

Referencing token in admin email 4 months 2 days ago #110077

  • ohvelma
  • ohvelma's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 39
  • Thank you received: 1
  • Karma: 1
My companies installation seems to work better with respect to embedding token table information into questions, but I am having difficulty on the LimeQuery 2.05 site. I think this behavior is new, I swear it worked last week ...
The administrator has disabled public write access.

Referencing token in admin email 4 months 1 day ago #110114

  • ohvelma
  • ohvelma's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 39
  • Thank you received: 1
  • Karma: 1
Attached is a sample survey created in version 2.05+ on the LimeQuery website. I find that references to token table fields fail. In this sample survey I have references in the Group Description text and also in the email template for the basic admin notification.

I think this may be a bug, but the thing is I had this working in this version previously so I am very puzzled.

I first discovered this issue on survey I am working on with a fairly tailored template. However the attached survey utilizes the basic template and I am getting the same behavior.
Attachments:
Last Edit: 4 months 1 day ago by ohvelma. Reason: fixing reference
The administrator has disabled public write access.

Referencing token in admin email 4 months 1 day ago #110116

  • ohvelma
  • ohvelma's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 39
  • Thank you received: 1
  • Karma: 1
Something changed on LimeQuery and all of the sudden token table variables are working again, yay!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.110 seconds
Donation Image