Welcome, Guest
Username: Password: Remember me

TOPIC: Conditional Question Groups

Conditional Question Groups 1 year 3 months ago #96699

  • mwillett
  • mwillett's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Is there a way to make an entire question group dependent on the answer to a previous question from a different group. I have tried to copy and paste the relevancy equation that shows up on the survey logic file into the field for the relevancy equation on the screen to edit the question group, but it is not showing up on the survey logic file as having a relevency equation attached to the group. If I copy it into the questions themselves, without setting it through the "set conditions" button, it does this as well. I guess that is two different questions any help with either would be greatly appreciated.

Thanks!

Mirranda
The administrator has disabled public write access.

Conditional Question Groups 1 year 3 months ago #96707

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4190
  • Thank you received: 787
  • Karma: 359
What LimeSurvey version are you using?

Can you post your relevancy equation?

The group relevance equation works for me (and appears in the logic file).
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Conditional Question Groups 1 year 3 months ago #96728

  • mwillett
  • mwillett's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
The bottom of my screen says I am using version 2.00+

This is what it looks like now on the question group:

Relevance: ((ROLE.NAOK == "1" or ROLE.NAOK == "4"))

This is now coming up on the survey logic screen when I check on it. I logged out and logged back in and this seemed to get it, and the group description, to show up in the survey logic screen. Yet when I go to copy conditions, it says there are no conditions in my survey.

Another question I have now is that when I make a question conditional it shows numbers instead of text in the relevance box on the edit screen. So I am wondering if the((ROLE.NAOK == "1" or ROLE.NAOK == "4"))will do anything for the group. I had tried it with the numbers in a different survey, but in the end it told me there were no conditions in my survey, even though numbers would show up on the actual question in the relevance field right below the question itself on the edit screen. I wish I knew more about programing and such. I feel like I could get so much more out of Limesurvey if I was more familiar with stuff like that.

Does any of that make sense?
The administrator has disabled public write access.

Conditional Question Groups 1 year 3 months ago #96731

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4190
  • Thank you received: 787
  • Karma: 359
Yet when I go to copy conditions, it says there are no conditions in my survey.
The Conditions Designer and Expression Manager (which handles relevance) are not 100% integrated. So, as far as I know, you cannot use the Conditions Designer to copy relevance equations entered directly into the field.

Another question I have now is that when I make a question conditional it shows numbers instead of text in the relevance box on the edit screen.
I think you should be able to use either the question code or the question SGQ in relevance equations.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.102 seconds
Donation Image