Welcome, Guest
Username: Password: Remember me

TOPIC: Token import - CSV file too big

Token import - CSV file too big 1 year 5 months ago #93096

  • joe_p
  • joe_p's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 1
  • Karma: 0
Does anyone know the limit on the number of tokens LimeSurvey can import at once? I have a large survey where we will be doing 50,000 at a time, and I have import errors when I cut that in half (25,000 at a time). 100 at a time works.

What is the limit here?
The administrator has disabled public write access.

Token import - CSV file too big 1 year 5 months ago #93098

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2605
  • Thank you received: 302
  • Karma: 110
I don't think the problem is the number of tokens, but the file size. This would depend very much on your server settings. What is the error message?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Token import - CSV file too big 1 year 5 months ago #93116

  • joe_p
  • joe_p's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 24
  • Thank you received: 1
  • Karma: 0
Thanks for the reply - I found the problem a short while after posting this (though I'd already been at it for a couple of hours).

I was getting a "limesurvey upload file not found" error, and it told me to check my permissions on the limesurvey/tmp/upload directory, but those weren't the issue.

My upload_max_filesize setting in PHP was the culprit - it was set to 2M. Adjusting this did the trick and let me run the large file.

Part of the confusion here also involved IIS, since our site runs on IIS - there is a setting there (maxRequestLength in the <httpRuntime> element) which has a default limit of 4M for file upload size. But it turned out PHP was the limiting factor here.
The administrator has disabled public write access.
The following user(s) said Thank You: holch

Token import - CSV file too big 1 year 5 months ago #93119

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2605
  • Thank you received: 302
  • Karma: 110
Thanks for the feedback. It is important to post the solution, even if you find it yourself as this might help others.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.108 seconds
Donation Image