Welcome, Guest
Username: Password: Remember me

TOPIC: Open link in new tab

Open link in new tab 2 years 1 month ago #85175

  • blacknail
  • blacknail's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 30
  • Thank you received: 1
  • Karma: 0
Hi all,

On my survey, I have links to some instructions (images), and I would like to open them in a new tab (or window), but as I've searched it through all the application, this forum and manual, I can't find how to do that.

Is that possible? Could it have to do with the version I'm using (Version 1.90+ Build 9596)?

Thanks to you all,
João Fernandes
The administrator has disabled public write access.

Re: Open link in new tab 2 years 1 month ago #85177

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2851
  • Thank you received: 359
  • Karma: 124
This actually has little to do with Limesurvey. This is a HTML or Javascript issue.

You either have to open the additional information in a popup window via Javascript (switch on javascript for your survey in the administration) or go with a good old html link with target="blank" (I think). Have a look on the internet, there should be plenty of examples.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: Open link in new tab 2 years 1 month ago #85355

  • blacknail
  • blacknail's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 30
  • Thank you received: 1
  • Karma: 0
Thanks for the quick reply, holch. Like you said and for future reference, it is as easy as editing the group / question you want, toggle fullscreen, and click in the "source" button. Then, you just have to edit the HTML and insert «target="_blank"» in the elements you want to open in a new tab.

Thanks,
João
The administrator has disabled public write access.

Re: Open link in new tab 1 year 11 months ago #88046

  • lamurph2
  • lamurph2's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
:( Evidently not as easy as all that. Every time I add the " target="_blank" html code and save the question the html disappears!!! Is it a bug that the html language you type in just disappears or changes?

This is the code I typed in:
<p>
If yes, please indicate the dataset(s) that you used from the list linked below:</p>
<pre>
<a href="calm.geo.berkeley.edu/ncalm/dtc.html" target="_blank"><span>NCALM Data Tracking Center</span></a></pre>

this is what I get when I save or save and close:
<p>
If yes, please indicate the dataset(s) that you used from the list linked below:</p>
<pre>
<a href="calm.geo.berkeley.edu/ncalm/dtc.html"><span>NCALM Data Tracking Center</span></a></pre>

Why is my " target="_blank" disappearing?
The administrator has disabled public write access.

Re: Open link in new tab 1 year 11 months ago #88066

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4277
  • Thank you received: 806
  • Karma: 370
I'm not sure why that is being sanitized (1.90 is quite old) but have you tried the editor "Link" button?
Attachments:
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
Last Edit: 1 year 11 months ago by tpartner.
The administrator has disabled public write access.

Re: Open link in new tab 1 year 11 months ago #88069

  • lamurph2
  • lamurph2's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Yes, I've tried that as well. It puts the coding in but when I save or save and close the coding either disappears or changes (i.e. the < and > signs change to &g).

I'm using this version of LimeSurvey: Version 2.00+ Build 121019
The administrator has disabled public write access.

Re: Open link in new tab 1 year 11 months ago #88070

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4277
  • Thank you received: 806
  • Karma: 370
Is the XSS filter turned off?

Capture2_2012-11-10.JPG
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: Open link in new tab 1 year 11 months ago #88071

  • lamurph2
  • lamurph2's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Nope it wasn't...that was the problem. All is good now. Thanks so much!!!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.110 seconds
Donation Image