Welcome, Guest
Username: Password: Remember me

TOPIC: Need help with prefilling questions

Need help with prefilling questions 2 years 6 months ago #80011

  • Raisis
  • Raisis's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Hi everybody,

I like to prefill two answers of my survey. It's a personal survey where I know my audience and I would like to prefill there name (it's a text input field)

So I've got a suvrey with the ID 999, the group ID is 1, questions ID is 1 question code is name.

I thought this link would prefill the question:

http://survey-link/index.php?sid=999&999X1X1name=MyName

But it does not work :(

Can you help me finding the mistake? Thank you :)
Last Edit: 2 years 6 months ago by Raisis.
The administrator has disabled public write access.

Re: Need help with prefilling questions 2 years 6 months ago #80018

  • tpartner
  • tpartner's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 4372
  • Thank you received: 830
  • Karma: 381
If it is a short-texr question, try:
survey-link/index.php?sid=999&999X1X1=MyName
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: Need help with prefilling questions 2 years 6 months ago #80026

  • Raisis
  • Raisis's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
I've tried it. And the field is still empty :(
The administrator has disabled public write access.

Re: Need help with prefilling questions 2 years 6 months ago #80030

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6561
  • Thank you received: 871
  • Karma: 257
try to add &newtest=Y to the url.

Denis
The administrator has disabled public write access.

Re: Need help with prefilling questions 2 years 6 months ago #80085

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5426
  • Thank you received: 307
  • Karma: 252
1. Which Limesurvey version do you use?

2. Did you set the question to be always hidden? If so and you change that setting, does it work fine?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.126 seconds
Donation Image