Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Trouble exporting to SPSS - Labels in Syntax-File

Re: Trouble exporting to SPSS - Labels in Syntax-File 2 years 6 months ago #80356

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
It used to work that variables are renamed to the question code. Here it tries to rename to the SGQID. Not sure why that happens, it never did before. Could be some kind of caching issue, where a cached fieldmap is used. Not really sure. If someone can provide the steps to reproduce, please file a bug report so I can look into it.
---
Menno Dekker
The administrator has disabled public write access.

Re: Trouble exporting to SPSS - Labels in Syntax-File 2 years 6 months ago #80357

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
By looking at the code I think randomization (and some error there) seems to cause the issue. Can you confirm this happens when randomization is on?
---
Menno Dekker
The administrator has disabled public write access.

Re: Trouble exporting to SPSS - Labels in Syntax-File 2 years 6 months ago #80361

  • lorien
  • lorien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
Do you mean random answer order? I never use this.
The problem is affect all off my questionnares.

Additional information: after installing 1.92 I had several bugs. I don't remember exactly but first was solved by replacing labels.php (from 1.91?), and the second issue (described here www.limesurvey.org/en/forum/installation...trange-erorr-message ) was solved by replacing activate_functions.php as written.
The administrator has disabled public write access.

Re: Trouble exporting to SPSS - Labels in Syntax-File 2 years 6 months ago #80372

  • mdekker
  • mdekker's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 341
  • Thank you received: 68
  • Karma: 38
Not able to reproduce here, so probably it was something caused by a failed upgrade. If you can reproduce on a clean install, please file a bugreport.
---
Menno Dekker
The administrator has disabled public write access.

Re: Trouble exporting to SPSS - Labels in Syntax-File 2 years 6 months ago #80373

  • lorien
  • lorien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
I cannot reproduce now, I must run this, there are several active surveys. But I'll have hard work on evaluation, because of the lack of working export: I can only export survey data to SPSS, without any labels :S
The administrator has disabled public write access.

Re: Trouble exporting to SPSS - Labels in Syntax-File 2 years 6 months ago #80468

  • Mazi
  • Mazi's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 5423
  • Thank you received: 307
  • Karma: 252
Try exporting the survey and the answers (VV export) and import those at another system (or our demo) and then test the SPSS export there.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Trouble exporting to SPSS - Labels in Syntax-File 2 years 5 months ago #81564

  • lorien
  • lorien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
I've tried to import the VV file on a newly installed limesurvey server. The problem is much bigger than I expected: all of answers are empty, i have only ids and status data (finished, lang).
SPSS syntax export from the new server is better than original system's and I succeed only a with a mixed solution: using spss data export from the original server and the syntax from the new i have now data in about the 80% percent of questions, but some columns still have missing.
The administrator has disabled public write access.

Re: Trouble exporting to SPSS - Labels in Syntax-File 2 years 5 months ago #81594

  • lorien
  • lorien's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 7
  • Karma: 0
After several tries, I managed as follows:
- made a new install of LS
- created a full sql dump from the original server
- uncommented utf8 settings
- restored the new databese from the original dump

I had only minor problems (in several surveys) with character encoding exported sps syntax and data. I solved by opening in Winword as UTF8 and saving with Central European Windows settings.
The administrator has disabled public write access.

Re: Trouble exporting to SPSS - Labels in Syntax-File 2 years 5 months ago #81657

  • Mazi
  • Mazi's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 5423
  • Thank you received: 307
  • Karma: 252
Hmm, might be a server setting related problem, because I have never heard about such a problem before.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.112 seconds
Donation Image